[4.14] how to use the new FlatSpark theme?

classic Classic list List threaded Threaded
77 messages Options
1234
Reply | Threaded
Open this post in threaded view
|

[4.14] how to use the new FlatSpark theme?

Erik de Bruin
Hi,

Would anyone care to share how we can use the new FlatSpark theme in
our projects? Maybe do a short Wiki article on the subject, with an
example project?

Thanks!

EdB



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Mahmoud Ali
I can write something in the wiki.
FlatSpark's GitHub had a wiki showing how to use it.

https://github.com/akamud/FlatSpark/wiki/How-to-use-FlatSpark-in-your-project

I just couldn't get the Flex SDK project to build for Flash Builder. Is
there any place I could download the 4.14 SDK to write this documentation?
Skype: muddibr
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Mahmoud Ali
I think I just found the binaries in Jenkins.

I'll write something showing how to use it when I get back from work.

On Mon, Dec 15, 2014 at 7:07 AM, Mahmoud Ali <[hidden email]> wrote:

>
> I can write something in the wiki.
> FlatSpark's GitHub had a wiki showing how to use it.
>
>
> https://github.com/akamud/FlatSpark/wiki/How-to-use-FlatSpark-in-your-project
>
> I just couldn't get the Flex SDK project to build for Flash Builder. Is
> there any place I could download the 4.14 SDK to write this documentation?
>
Skype: muddibr
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Erik de Bruin
In reply to this post by Mahmoud Ali
Hi,

Thanks for the link.

You can download the 4.14 candidate through the Installer, just follow
the instructions in the thread "testing is easy!"

Thanks,

EdB



On Mon, Dec 15, 2014 at 11:07 AM, Mahmoud Ali <[hidden email]> wrote:
> I can write something in the wiki.
> FlatSpark's GitHub had a wiki showing how to use it.
>
> https://github.com/akamud/FlatSpark/wiki/How-to-use-FlatSpark-in-your-project
>
> I just couldn't get the Flex SDK project to build for Flash Builder. Is
> there any place I could download the 4.14 SDK to write this documentation?



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Mahmoud Ali
Thanks Erik.

Where can I write this wiki or add this example project?

Do you want me to just create a new wiki page inside FlatSpark's GitHub
page and then you take it from there?

On Mon, Dec 15, 2014 at 7:09 AM, Erik de Bruin <[hidden email]> wrote:

>
> Hi,
>
> Thanks for the link.
>
> You can download the 4.14 candidate through the Installer, just follow
> the instructions in the thread "testing is easy!"
>
> Thanks,
>
> EdB
>
>
>
> On Mon, Dec 15, 2014 at 11:07 AM, Mahmoud Ali <[hidden email]> wrote:
> > I can write something in the wiki.
> > FlatSpark's GitHub had a wiki showing how to use it.
> >
> >
> https://github.com/akamud/FlatSpark/wiki/How-to-use-FlatSpark-in-your-project
> >
> > I just couldn't get the Flex SDK project to build for Flash Builder. Is
> > there any place I could download the 4.14 SDK to write this
> documentation?
>
>
>
> --
> Ix Multimedia Software
>
> Jan Luykenstraat 27
> 3521 VB Utrecht
>
> T. 06-51952295
> I. www.ixsoftware.nl
>
Skype: muddibr
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Erik de Bruin
> Do you want me to just create a new wiki page inside FlatSpark's GitHub page
> and then you take it from there?

Yes, that would be fine. Let me know in this thread when it's
available and I'll 'copy' it to the Flex Wiki. Thank you.

EdB



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Tom Chiverton-2
In reply to this post by Mahmoud Ali
I think writing it directly on the Apache Flex Wiki, maybe as a child of
https://cwiki.apache.org/confluence/display/FLEX/Guides+and+Reference
is going to be best.

We just need to grant you access I think ?
Tom

On 15/12/14 10:16, Mahmoud Ali wrote:

> Thanks Erik.
>
> Where can I write this wiki or add this example project?
>
> Do you want me to just create a new wiki page inside FlatSpark's GitHub
> page and then you take it from there?
>
> On Mon, Dec 15, 2014 at 7:09 AM, Erik de Bruin <[hidden email]> wrote:
>> Hi,
>>
>> Thanks for the link.
>>
>> You can download the 4.14 candidate through the Installer, just follow
>> the instructions in the thread "testing is easy!"
>>
>> Thanks,
>>
>> EdB
>>
>>
>>
>> On Mon, Dec 15, 2014 at 11:07 AM, Mahmoud Ali <[hidden email]> wrote:
>>> I can write something in the wiki.
>>> FlatSpark's GitHub had a wiki showing how to use it.
>>>
>>>
>> https://github.com/akamud/FlatSpark/wiki/How-to-use-FlatSpark-in-your-project
>>> I just couldn't get the Flex SDK project to build for Flash Builder. Is
>>> there any place I could download the 4.14 SDK to write this
>> documentation?
>>
>>
>>
>> --
>> Ix Multimedia Software
>>
>> Jan Luykenstraat 27
>> 3521 VB Utrecht
>>
>> T. 06-51952295
>> I. www.ixsoftware.nl
>>
>
> ______________________________________________________________________
> This email has been scanned by the Symantec Email Security.cloud service.
> For more information please visit http://www.symanteccloud.com
> ______________________________________________________________________

Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Erik de Bruin
In reply to this post by Mahmoud Ali
Mahmoud,

Using the GitHub wiki article I've tried to create a new project,
chose 4.14 RC SDK and add one button.

If I try to give this button the FlatSpark look by using the
'skinClass' property directly in MXML, I get 33 compiler errors,
starting with a dozen or so "Exception during transcoding:".

If I try to give the button the FlatSpark look using a CSS declaration
in an MXML style section ("s|Button { skinClass:
"flatspark.skins.ButtonSkin"; }"), I get this runtime error:

<error>
Error: Skin for
Main.ApplicationSkin2.containerGrp.contentGroup.VGroup5.Button6 cannot
be found.
at spark.components.supportClasses::SkinnableComponent/attachSkin()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/supportClasses/SkinnableComponent.as:713]
at spark.components.supportClasses::SkinnableComponent/validateSkinChange()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/supportClasses/SkinnableComponent.as:457]
at spark.components.supportClasses::SkinnableComponent/createChildren()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/supportClasses/SkinnableComponent.as:416]
at mx.core::UIComponent/initialize()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/core/UIComponent.as:7695]
at mx.core::UIComponent/http://www.adobe.com/2006/flex/mx/internal::childAdded()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/core/UIComponent.as:7556]
at mx.core::UIComponent/addChildAt()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/core/UIComponent.as:7260]
at spark.components::Group/addDisplayObjectToDisplayList()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/Group.as:2116]
at spark.components::Group/http://www.adobe.com/2006/flex/mx/internal::elementAdded()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/Group.as:1707]
at spark.components::Group/setMXMLContent()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/Group.as:653]
at spark.components::Group/createChildren()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/Group.as:906]
at mx.core::UIComponent/initialize()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/core/UIComponent.as:7695]
at mx.core::UIComponent/http://www.adobe.com/2006/flex/mx/internal::childAdded()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/core/UIComponent.as:7556]
at mx.core::UIComponent/addChildAt()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/core/UIComponent.as:7260]
at spark.components::Group/addDisplayObjectToDisplayList()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/Group.as:2116]
at spark.components::Group/http://www.adobe.com/2006/flex/mx/internal::elementAdded()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/Group.as:1707]
at spark.components::Group/setMXMLContent()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/Group.as:653]
at spark.components::Group/set
mxmlContent()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/Group.as:593]
at spark.components::SkinnableContainer/set
mxmlContent()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/SkinnableContainer.as:665]
at spark.components::SkinnableContainer/createDeferredContent()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/SkinnableContainer.as:1092]
at spark.components::SkinnableContainer/createContentIfNeeded()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/SkinnableContainer.as:1120]
at spark.components::SkinnableContainer/createChildren()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/SkinnableContainer.as:915]
at spark.components::Application/createChildren()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/Application.as:1564]
at mx.core::UIComponent/initialize()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/core/UIComponent.as:7695]
at spark.components::Application/initialize()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/spark/src/spark/components/Application.as:1387]
at Main/initialize()
at mx.managers.systemClasses::ChildManager/childAdded()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/managers/systemClasses/ChildManager.as:197]
at mx.managers.systemClasses::ChildManager/initializeTopLevelWindow()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/managers/systemClasses/ChildManager.as:367]
at mx.managers::SystemManager/initializeTopLevelWindow()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/managers/SystemManager.as:3065]
at mx.managers::SystemManager/http://www.adobe.com/2006/flex/mx/internal::kickOff()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/managers/SystemManager.as:2851]
at mx.managers::SystemManager/http://www.adobe.com/2006/flex/mx/internal::preloader_completeHandler()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/managers/SystemManager.as:2731]
at flash.events::EventDispatcher/dispatchEventFunction()
at flash.events::EventDispatcher/dispatchEvent()
at mx.preloaders::Preloader/timerHandler()[/Users/erik/Documents/ApacheFlex/git/flex-sdk/frameworks/projects/framework/src/mx/preloaders/Preloader.as:572]
at flash.utils::Timer/_timerDispatch()
at flash.utils::Timer/tick()
</error>

Thanks,

EdB



On Mon, Dec 15, 2014 at 11:07 AM, Mahmoud Ali <[hidden email]> wrote:
> I can write something in the wiki.
> FlatSpark's GitHub had a wiki showing how to use it.
>
> https://github.com/akamud/FlatSpark/wiki/How-to-use-FlatSpark-in-your-project
>
> I just couldn't get the Flex SDK project to build for Flash Builder. Is
> there any place I could download the 4.14 SDK to write this documentation?



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Mahmoud Ali
>
> Mahmoud,
>
> Using the GitHub wiki article I've tried to create a new project,
> chose 4.14 RC SDK and add one button.
>
> If I try to give this button the FlatSpark look by using the
> 'skinClass' property directly in MXML, I get 33 compiler errors,
> starting with a dozen or so "Exception during transcoding:".


Never had these errors before. I'll take a look at this today as soon as I
get back home.
Can you provide a Gist showing the code you wrote?

Thanks.
Skype: muddibr
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Erik de Bruin
> Never had these errors before. I'll take a look at this today as soon as I
> get back home.

Never mind. It turns out it was just me on a Monday morning :-(

Sorry for the waste of time.

EdB



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Mahmoud Ali
>
> Never mind. It turns out it was just me on a Monday morning :-(
>
> Sorry for the waste of time.
>
> EdB


Haha, I know that feel.
Either way, I'll write the wiki article tonight.
Thanks for testing :)
Skype: muddibr
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Dany Dhondt
What was your mistake? I get the same 33 errors :)


Dany Dhondt
[hidden email] | Mobile +32 496 251 455




> Op 15-dec.-2014, om 13:17 heeft Mahmoud Ali <[hidden email]> het volgende geschreven:
>
>>
>> Never mind. It turns out it was just me on a Monday morning :-(
>>
>> Sorry for the waste of time.
>>
>> EdB
>
>
> Haha, I know that feel.
> Either way, I'll write the wiki article tonight.
> Thanks for testing :)

Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Alex Harui
In reply to this post by Tom Chiverton-2


On 12/15/14, 2:31 AM, "Tom Chiverton" <[hidden email]> wrote:

>I think writing it directly on the Apache Flex Wiki, maybe as a child of
>https://cwiki.apache.org/confluence/display/FLEX/Guides+and+Reference
>is going to be best.
>
>We just need to grant you access I think ?

Wiki has a different list of accounts.  Mahmoud can sign up for a wiki
account from any wiki page if he doesn’t have one already.  Then he tells
us his account name and then we grant write permission.

-Alex

Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Erik de Bruin
In reply to this post by Dany Dhondt
I had selected an SDK where I manually removed the flatspark.swc :-)

So, in your case, maybe it is actually missing ... can you check in
'[SDK root]/frameworks/libs'?

EdB



On Mon, Dec 15, 2014 at 2:52 PM, Dany Dhondt <[hidden email]> wrote:

> What was your mistake? I get the same 33 errors :)
>
>
> Dany Dhondt
> [hidden email] | Mobile +32 496 251 455
>
>
>
>
>> Op 15-dec.-2014, om 13:17 heeft Mahmoud Ali <[hidden email]> het volgende geschreven:
>>
>>>
>>> Never mind. It turns out it was just me on a Monday morning :-(
>>>
>>> Sorry for the waste of time.
>>>
>>> EdB
>>
>>
>> Haha, I know that feel.
>> Either way, I'll write the wiki article tonight.
>> Thanks for testing :)
>



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Mahmoud Ali
I just created an account on the wiki page. Username: akamud

On Mon, Dec 15, 2014 at 2:08 PM, Erik de Bruin <[hidden email]> wrote:

>
> I had selected an SDK where I manually removed the flatspark.swc :-)
>
> So, in your case, maybe it is actually missing ... can you check in
> '[SDK root]/frameworks/libs'?
>
> EdB
>
>
>
> On Mon, Dec 15, 2014 at 2:52 PM, Dany Dhondt <[hidden email]> wrote:
> > What was your mistake? I get the same 33 errors :)
> >
> >
> > Dany Dhondt
> > [hidden email] | Mobile +32 496 251 455
> >
> >
> >
> >
> >> Op 15-dec.-2014, om 13:17 heeft Mahmoud Ali <[hidden email]> het
> volgende geschreven:
> >>
> >>>
> >>> Never mind. It turns out it was just me on a Monday morning :-(
> >>>
> >>> Sorry for the waste of time.
> >>>
> >>> EdB
> >>
> >>
> >> Haha, I know that feel.
> >> Either way, I'll write the wiki article tonight.
> >> Thanks for testing :)
> >
>
>
>
> --
> Ix Multimedia Software
>
> Jan Luykenstraat 27
> 3521 VB Utrecht
>
> T. 06-51952295
> I. www.ixsoftware.nl
>
Skype: muddibr
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Alex Harui


On 12/15/14, 3:39 PM, "Mahmoud Ali" <[hidden email]> wrote:

>I just created an account on the wiki page. Username: akamud

OK, you should have permissions

Sorry for the delay,
-Alex

Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Dany Dhondt
In reply to this post by Erik de Bruin
Eric,

flatspark.swc is there but I still get the errors. It has to do with the fonts I think.

First, there are a lot of these:

exception during transcoding: client

And then these:

unable to build font 'FontAwesome'
same for Lato, LatoBlack etc..



Dany



> Op 15-dec.-2014, om 18:08 heeft Erik de Bruin <[hidden email] <mailto:[hidden email]>> het volgende geschreven:
>
> I had selected an SDK where I manually removed the flatspark.swc :-)
>
> So, in your case, maybe it is actually missing ... can you check in
> '[SDK root]/frameworks/libs'?
>
> EdB
>
>
>
> On Mon, Dec 15, 2014 at 2:52 PM, Dany Dhondt <[hidden email] <mailto:[hidden email]>> wrote:
>> What was your mistake? I get the same 33 errors :)
>>
>>
>> Dany Dhondt
>> [hidden email] <mailto:[hidden email]> | Mobile +32 496 251 455
>>
>>
>>
>>
>>> Op 15-dec.-2014, om 13:17 heeft Mahmoud Ali <[hidden email] <mailto:[hidden email]>> het volgende geschreven:
>>>
>>>>
>>>> Never mind. It turns out it was just me on a Monday morning :-(
>>>>
>>>> Sorry for the waste of time.
>>>>
>>>> EdB
>>>
>>>
>>> Haha, I know that feel.
>>> Either way, I'll write the wiki article tonight.
>>> Thanks for testing :)
>>
>
>
>
> --
> Ix Multimedia Software
>
> Jan Luykenstraat 27
> 3521 VB Utrecht
>
> T. 06-51952295
> I. www.ixsoftware.nl <http://www.ixsoftware.nl/>

Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Erik de Bruin
I also managed to get this error when I forgot to put the curly braces
inside the property declaration, like so:

good: skinClass="{flatspark.skins.ButtonSkin}", but I had:
skinClass="flatspark.skins.ButtonSkin"

HTH,

EdB



On Tue, Dec 16, 2014 at 9:26 AM, Dany Dhondt <[hidden email]> wrote:

> Eric,
>
> flatspark.swc is there but I still get the errors. It has to do with the fonts I think.
>
> First, there are a lot of these:
>
> exception during transcoding:   client
>
> And then these:
>
> unable to build font 'FontAwesome'
> same for Lato, LatoBlack etc..
>
>
>
> Dany
>
>
>
>> Op 15-dec.-2014, om 18:08 heeft Erik de Bruin <[hidden email] <mailto:[hidden email]>> het volgende geschreven:
>>
>> I had selected an SDK where I manually removed the flatspark.swc :-)
>>
>> So, in your case, maybe it is actually missing ... can you check in
>> '[SDK root]/frameworks/libs'?
>>
>> EdB
>>
>>
>>
>> On Mon, Dec 15, 2014 at 2:52 PM, Dany Dhondt <[hidden email] <mailto:[hidden email]>> wrote:
>>> What was your mistake? I get the same 33 errors :)
>>>
>>>
>>> Dany Dhondt
>>> [hidden email] <mailto:[hidden email]> | Mobile +32 496 251 455
>>>
>>>
>>>
>>>
>>>> Op 15-dec.-2014, om 13:17 heeft Mahmoud Ali <[hidden email] <mailto:[hidden email]>> het volgende geschreven:
>>>>
>>>>>
>>>>> Never mind. It turns out it was just me on a Monday morning :-(
>>>>>
>>>>> Sorry for the waste of time.
>>>>>
>>>>> EdB
>>>>
>>>>
>>>> Haha, I know that feel.
>>>> Either way, I'll write the wiki article tonight.
>>>> Thanks for testing :)
>>>
>>
>>
>>
>> --
>> Ix Multimedia Software
>>
>> Jan Luykenstraat 27
>> 3521 VB Utrecht
>>
>> T. 06-51952295
>> I. www.ixsoftware.nl <http://www.ixsoftware.nl/>
>



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

piotrz
Erik,

Actually this skinClass="flatspark.skins.ButtonSkin"  also should work :)

Piotr
Reply | Threaded
Open this post in threaded view
|

Re: [4.14] how to use the new FlatSpark theme?

Erik de Bruin
In which case, we've found an issue...

EdB



On Tue, Dec 16, 2014 at 9:58 AM, piotrz <[hidden email]> wrote:

> Erik,
>
> Actually this skinClass="flatspark.skins.ButtonSkin"  also should work :)
>
> Piotr
>
>
>
> -----
> Apache Flex PMC
> [hidden email]
> --
> View this message in context: http://apache-flex-development.2333347.n4.nabble.com/4-14-how-to-use-the-new-FlatSpark-theme-tp43479p43552.html
> Sent from the Apache Flex Development mailing list archive at Nabble.com.



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl
1234