Can't debug. Plug-ins do nothing.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't debug. Plug-ins do nothing.

Dannemann
I cannot debug after installing the debuggers (version 31).

I looks like firefox has disabled npapi and edge has it sandboxed.. I saw a
topic in microsoft where the support says it is impossible to debug in it
right now.. same thing in chrome.. I am using windows 10 and the most
updated browsers

I get the message "To view this page ensure that Adobe Flash Player version
31.0.0 or greater is installed. "

thank you in advance



--
Sent from: http://apache-flex-development.2333347.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Can't debug. Plug-ins do nothing.

piotrz
Hi Dannemann,

If I remember correctly you have to push your application to the server.
Open in the browser and than attach debugger. This is the only way of
resolving that issue.

Thanks, Piotr

pt., 7 gru 2018 o 05:52 Dannemann <[hidden email]> napisał(a):

> I cannot debug after installing the debuggers (version 31).
>
> I looks like firefox has disabled npapi and edge has it sandboxed.. I saw a
> topic in microsoft where the support says it is impossible to debug in it
> right now.. same thing in chrome.. I am using windows 10 and the most
> updated browsers
>
> I get the message "To view this page ensure that Adobe Flash Player version
> 31.0.0 or greater is installed. "
>
> thank you in advance
>
>
>
> --
> Sent from: http://apache-flex-development.2333347.n4.nabble.com/
>


--

Piotr Zarzycki

Patreon: *https://www.patreon.com/piotrzarzycki
<https://www.patreon.com/piotrzarzycki>*
Reply | Threaded
Open this post in threaded view
|

Re: Can't debug. Plug-ins do nothing.

Greg Dove
I went through this not so long ago. fyi the best option I found was Opera.
It's now like Chrome, but flash debugging still worked for me. If you can't
get anything else to work, you might want to try that.



On Fri, Dec 7, 2018 at 6:27 PM Piotr Zarzycki <[hidden email]>
wrote:

> Hi Dannemann,
>
> If I remember correctly you have to push your application to the server.
> Open in the browser and than attach debugger. This is the only way of
> resolving that issue.
>
> Thanks, Piotr
>
> pt., 7 gru 2018 o 05:52 Dannemann <[hidden email]> napisał(a):
>
> > I cannot debug after installing the debuggers (version 31).
> >
> > I looks like firefox has disabled npapi and edge has it sandboxed.. I
> saw a
> > topic in microsoft where the support says it is impossible to debug in it
> > right now.. same thing in chrome.. I am using windows 10 and the most
> > updated browsers
> >
> > I get the message "To view this page ensure that Adobe Flash Player
> version
> > 31.0.0 or greater is installed. "
> >
> > thank you in advance
> >
> >
> >
> > --
> > Sent from: http://apache-flex-development.2333347.n4.nabble.com/
> >
>
>
> --
>
> Piotr Zarzycki
>
> Patreon: *https://www.patreon.com/piotrzarzycki
> <https://www.patreon.com/piotrzarzycki>*
>
Reply | Threaded
Open this post in threaded view
|

Re: Can't debug. Plug-ins do nothing.

piotrz
Hi Greg,

Good to know about Opera!

Thanks for that!
Piotr

On Fri, Dec 7, 2018, 8:03 AM Greg Dove <[hidden email]> wrote:

> I went through this not so long ago. fyi the best option I found was Opera.
> It's now like Chrome, but flash debugging still worked for me. If you can't
> get anything else to work, you might want to try that.
>
>
>
> On Fri, Dec 7, 2018 at 6:27 PM Piotr Zarzycki <[hidden email]>
> wrote:
>
> > Hi Dannemann,
> >
> > If I remember correctly you have to push your application to the server.
> > Open in the browser and than attach debugger. This is the only way of
> > resolving that issue.
> >
> > Thanks, Piotr
> >
> > pt., 7 gru 2018 o 05:52 Dannemann <[hidden email]> napisał(a):
> >
> > > I cannot debug after installing the debuggers (version 31).
> > >
> > > I looks like firefox has disabled npapi and edge has it sandboxed.. I
> > saw a
> > > topic in microsoft where the support says it is impossible to debug in
> it
> > > right now.. same thing in chrome.. I am using windows 10 and the most
> > > updated browsers
> > >
> > > I get the message "To view this page ensure that Adobe Flash Player
> > version
> > > 31.0.0 or greater is installed. "
> > >
> > > thank you in advance
> > >
> > >
> > >
> > > --
> > > Sent from: http://apache-flex-development.2333347.n4.nabble.com/
> > >
> >
> >
> > --
> >
> > Piotr Zarzycki
> >
> > Patreon: *https://www.patreon.com/piotrzarzycki
> > <https://www.patreon.com/piotrzarzycki>*
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: Can't debug. Plug-ins do nothing.

Alex Harui-2
I just checked today.  For me, on Mac, the debugger plugin works fine on Safari 12.  On Windows, I use an older Firefox (47) for compatibility with the version of Selenium we currently use in Royale.  That is before the NPAPI deprecation.  And the debugger plugin works fine in that older Firefox.

This article says there is an ESR version of Firefox that might work.  https://support.mozilla.org/en-US/questions/1176670

HTH,
-Alex

On 12/6/18, 11:29 PM, "Piotr Zarzycki" <[hidden email]> wrote:

    Hi Greg,
   
    Good to know about Opera!
   
    Thanks for that!
    Piotr
   
    On Fri, Dec 7, 2018, 8:03 AM Greg Dove <[hidden email]> wrote:
   
    > I went through this not so long ago. fyi the best option I found was Opera.
    > It's now like Chrome, but flash debugging still worked for me. If you can't
    > get anything else to work, you might want to try that.
    >
    >
    >
    > On Fri, Dec 7, 2018 at 6:27 PM Piotr Zarzycki <[hidden email]>
    > wrote:
    >
    > > Hi Dannemann,
    > >
    > > If I remember correctly you have to push your application to the server.
    > > Open in the browser and than attach debugger. This is the only way of
    > > resolving that issue.
    > >
    > > Thanks, Piotr
    > >
    > > pt., 7 gru 2018 o 05:52 Dannemann <[hidden email]> napisał(a):
    > >
    > > > I cannot debug after installing the debuggers (version 31).
    > > >
    > > > I looks like firefox has disabled npapi and edge has it sandboxed.. I
    > > saw a
    > > > topic in microsoft where the support says it is impossible to debug in
    > it
    > > > right now.. same thing in chrome.. I am using windows 10 and the most
    > > > updated browsers
    > > >
    > > > I get the message "To view this page ensure that Adobe Flash Player
    > > version
    > > > 31.0.0 or greater is installed. "
    > > >
    > > > thank you in advance
    > > >
    > > >
    > > >
    > > > --
    > > > Sent from: https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-flex-development.2333347.n4.nabble.com%2F&amp;data=02%7C01%7Caharui%40adobe.com%7Cc6e7efb23a3449c44ce008d65c15b4fa%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636797645636876217&amp;sdata=AO219YYpOjgROO51rNu%2BIE%2BLdyVpvdn0M8cf4mW8W6I%3D&amp;reserved=0
    > > >
    > >
    > >
    > > --
    > >
    > > Piotr Zarzycki
    > >
    > > Patreon: *https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.patreon.com%2Fpiotrzarzycki&amp;data=02%7C01%7Caharui%40adobe.com%7Cc6e7efb23a3449c44ce008d65c15b4fa%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636797645636876217&amp;sdata=y3lDgYRjXSR5w4Hyii7VgXlV6wzDIDp0U9vzkASlKPg%3D&amp;reserved=0
    > > <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.patreon.com%2Fpiotrzarzycki&amp;data=02%7C01%7Caharui%40adobe.com%7Cc6e7efb23a3449c44ce008d65c15b4fa%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636797645636876217&amp;sdata=y3lDgYRjXSR5w4Hyii7VgXlV6wzDIDp0U9vzkASlKPg%3D&amp;reserved=0>*
    > >
    >
   

Reply | Threaded
Open this post in threaded view
|

Re: Can't debug. Plug-ins do nothing.

Dannemann
In reply to this post by Dannemann
Thanks for the tips guys.

I was able to do it by:

1) Uninstalling Firefox Flash player
(https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html).

2) Install NPAPI debugger.

3) On Firefox, go to "Open menu -> Add-ons -> Shockwave Flash (click
'Options' or 'More')" and then *uncheck* "Block dangerous and intrusive
Flash content".



--
Sent from: http://apache-flex-development.2333347.n4.nabble.com/