[FlexJS] Failing build for simple example

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[FlexJS] Failing build for simple example

piotrz
Hi,

With Santanu we did build FlexJS SDK by Ant and tried to use this version to build simple example. We are  getting following error [1]. Does anyone know what could happen ?

[1] https://paste.apache.org/HQcd

Thanks,
Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS] Failing build for simple example

Josh Tynjala
I'm guessing that you didn't update the compiler before building the SDK. I
think that fxg-base-class is a somewhat new compiler option.

- Josh

On Fri, Aug 4, 2017 at 8:42 AM, piotrz <[hidden email]> wrote:

> Hi,
>
> With Santanu we did build FlexJS SDK by Ant and tried to use this version
> to
> build simple example. We are  getting following error [1]. Does anyone know
> what could happen ?
>
> [1] https://paste.apache.org/HQcd
>
> Thanks,
> Piotr
>
>
>
> -----
> Apache Flex PMC
> [hidden email]
> --
> View this message in context: http://apache-flex-
> development.2333347.n4.nabble.com/FlexJS-Failing-build-for-
> simple-example-tp63695.html
> Sent from the Apache Flex Development mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS] Failing build for simple example

sankar
Josh Tynjala wrote
I'm guessing that you didn't update the compiler before building the SDK. I
think that fxg-base-class is a somewhat new compiler option.
Hi Josh,

We downloaded all these following packages fresh before start our Ant SDK build:

- flex-asjs
- flex-falcon
- flex-blazeds
- flex-flexunit
- flex-sdk
- flex-tlf
- flex-typedefs

Piotr mentioned that new compiler options we need updated flex-falcon builds.

Inside our binary distribution folder, and before running "ant -f installer.xml" inside the folder, we downloaded most last and latest compiled versions of flex-falcon from here http://apacheflexbuild.cloudapp.net:8080/job/flex-falcon/lastSuccessfulBuild/artifact/ to "in" folder. I guess flex-falcon requires in this step of Ant procedure.

Upon running "ant -f installer.xml" we had no trouble and we have produced with a complete FlexJS 0.9.0 SDK as well.

But when build running on a basic FlexJS project, we're continue to get this error:
: -optimize=false
: -compiler.targets=JSFLEX
: Unknown tag:compiler.fxg-base-class
: Unknown tag:compiler.fxg-base-class
: E:\DevareaLocal\ApacheFlexJSFrameworkSource\source\flex-asjs\out\apache-flex-flexjs-0.9.0-bin\frameworks\flex-config.xml(127): col: 0 unknown configuration variable 'compiler.fxg-base-class'.
: E:\DevareaLocal\ApacheFlexJSFrameworkSource\source\flex-asjs\out\apache-flex-flexjs-0.9.0-bin\frameworks\flex-config.xml (line: 127)
:
:       <fxg-base-class>flash.display.Sprite</fxg-base-class>
:
:
: E:\DevareaLocal\ApacheFlexJSFrameworkSource\source\flex-asjs\out\apache-flex-flexjs-0.9.0-bin\frameworks\flex-config.xml(127): col: 0 unknown configuration variable 'compiler.fxg-base-class'.
: E:\DevareaLocal\ApacheFlexJSFrameworkSource\source\flex-asjs\out\apache-flex-flexjs-0.9.0-bin\frameworks\flex-config.xml (line: 127)
:
:       <fxg-base-class>flash.display.Sprite</fxg-base-class>
Per Piotr's temporary solution, if I comment out that line#127 from flex-config, I able to build/run a project; Although, I don't know what it's (removal) long time effect.

Thanks!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS] Failing build for simple example

piotrz
In reply to this post by piotrz
Hi,

This option "<fxg-base-class>flash.display.Sprite</fxg-base-class>" flex-config seems to breaking code completion in Moonshine.

I've just configured Moonshine on clean Windows 7 PC and started to getting following things in console [1]. Once I commented out in flex-config that option everything started to work.

Anyone have an idea where the problem could be ?

[1] https://paste.apache.org/KknK

Thanks,
Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Re: [FlexJS] Failing build for simple example

after24
Bonjour,

En congés jusqu'au 4 septembre, je prendrais connaissance de votre message à mon retour.

Cordialement,

Vincent/AFTER24



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS] Failing build for simple example

Josh Tynjala
In reply to this post by piotrz
Moonshine currently uses the 0.8.0 compiler for code intelligence. Nightly
builds of FlexJS specify a new fxg-base-class compiler option in
flex-config.xml, but this compiler option didn't exist in 0.8.0.

There is currently no way to force Moonshine to use the newer compiler for
code intelligence instead of the version that it bundles.

- Josh


On Wed, Aug 16, 2017 at 10:19 AM, piotrz <[hidden email]> wrote:

> Hi,
>
> This option "<fxg-base-class>flash.display.Sprite</fxg-base-class>"
> flex-config seems to breaking code completion in Moonshine.
>
> I've just configured Moonshine on clean Windows 7 PC and started to getting
> following things in console [1]. Once I commented out in flex-config that
> option everything started to work.
>
> Anyone have an idea where the problem could be ?
>
> [1] https://paste.apache.org/KknK
>
> Thanks,
> Piotr
>
>
>
> -----
> Apache Flex PMC
> [hidden email]
> --
> View this message in context: http://apache-flex-
> development.2333347.n4.nabble.com/FlexJS-Failing-build-for-
> simple-example-tp63695p63895.html
> Sent from the Apache Flex Development mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS] Failing build for simple example

Alex Harui-2
Bummer.  There is no way to overwrite the compiler jars?

-Alex

On 8/16/17, 10:34 AM, "Josh Tynjala" <[hidden email]> wrote:

>Moonshine currently uses the 0.8.0 compiler for code intelligence. Nightly
>builds of FlexJS specify a new fxg-base-class compiler option in
>flex-config.xml, but this compiler option didn't exist in 0.8.0.
>
>There is currently no way to force Moonshine to use the newer compiler for
>code intelligence instead of the version that it bundles.
>
>- Josh
>
>
>On Wed, Aug 16, 2017 at 10:19 AM, piotrz <[hidden email]>
>wrote:
>
>> Hi,
>>
>> This option "<fxg-base-class>flash.display.Sprite</fxg-base-class>"
>> flex-config seems to breaking code completion in Moonshine.
>>
>> I've just configured Moonshine on clean Windows 7 PC and started to
>>getting
>> following things in console [1]. Once I commented out in flex-config
>>that
>> option everything started to work.
>>
>> Anyone have an idea where the problem could be ?
>>
>> [1]
>>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fpaste.ap
>>ache.org%2FKknK&data=02%7C01%7C%7C59f55fbd7a1b4640335c08d4e4cd1ded%7Cfa7b
>>1b5a7b34438794aed2c178decee1%7C0%7C0%7C636385016997138868&sdata=l9KP2Eqnf
>>4vupyT8Wqx1zXgIprKrdZlPhdBvIBUyX8Q%3D&reserved=0
>>
>> Thanks,
>> Piotr
>>
>>
>>
>> -----
>> Apache Flex PMC
>> [hidden email]
>> --
>> View this message in context: http://apache-flex-
>> development.2333347.n4.nabble.com/FlexJS-Failing-build-for-
>> simple-example-tp63695p63895.html
>> Sent from the Apache Flex Development mailing list archive at
>>Nabble.com.
>>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS] Failing build for simple example

Josh Tynjala
Everything is compiled into a single "fat" JAR, so unfortunately no.

- Josh

On Wed, Aug 16, 2017 at 10:44 AM, Alex Harui <[hidden email]>
wrote:

> Bummer.  There is no way to overwrite the compiler jars?
>
> -Alex
>
> On 8/16/17, 10:34 AM, "Josh Tynjala" <[hidden email]> wrote:
>
> >Moonshine currently uses the 0.8.0 compiler for code intelligence. Nightly
> >builds of FlexJS specify a new fxg-base-class compiler option in
> >flex-config.xml, but this compiler option didn't exist in 0.8.0.
> >
> >There is currently no way to force Moonshine to use the newer compiler for
> >code intelligence instead of the version that it bundles.
> >
> >- Josh
> >
> >
> >On Wed, Aug 16, 2017 at 10:19 AM, piotrz <[hidden email]>
> >wrote:
> >
> >> Hi,
> >>
> >> This option "<fxg-base-class>flash.display.Sprite</fxg-base-class>"
> >> flex-config seems to breaking code completion in Moonshine.
> >>
> >> I've just configured Moonshine on clean Windows 7 PC and started to
> >>getting
> >> following things in console [1]. Once I commented out in flex-config
> >>that
> >> option everything started to work.
> >>
> >> Anyone have an idea where the problem could be ?
> >>
> >> [1]
> >>https://na01.safelinks.protection.outlook.com/?url=
> https%3A%2F%2Fpaste.ap
> >>ache.org%2FKknK&data=02%7C01%7C%7C59f55fbd7a1b4640335c08d4e4cd
> 1ded%7Cfa7b
> >>1b5a7b34438794aed2c178decee1%7C0%7C0%7C636385016997138868&
> sdata=l9KP2Eqnf
> >>4vupyT8Wqx1zXgIprKrdZlPhdBvIBUyX8Q%3D&reserved=0
> >>
> >> Thanks,
> >> Piotr
> >>
> >>
> >>
> >> -----
> >> Apache Flex PMC
> >> [hidden email]
> >> --
> >> View this message in context: http://apache-flex-
> >> development.2333347.n4.nabble.com/FlexJS-Failing-build-for-
> >> simple-example-tp63695p63895.html
> >> Sent from the Apache Flex Development mailing list archive at
> >>Nabble.com.
> >>
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS] Failing build for simple example

piotrz
The bundled jars are using released version of compiler, so the deal is to release new version.

Then it could be used there?

Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS] Failing build for simple example

Josh Tynjala
Yes, if we release a new version of the compiler, then Moonshine can be
updated to use it.

Alternatively, Moonshine could be refactored to allow users to optionally
point to a different version of the compiler, similar to how the VSCode
extension provides the nextgenas.sdk.editor setting.

- Josh

On Wed, Aug 16, 2017 at 10:56 AM, piotrz <[hidden email]> wrote:

> The bundled jars are using released version of compiler, so the deal is to
> release new version.
>
> Then it could be used there?
>
> Piotr
>
>
>
> -----
> Apache Flex PMC
> [hidden email]
> --
> View this message in context: http://apache-flex-
> development.2333347.n4.nabble.com/FlexJS-Failing-build-for-
> simple-example-tp63695p63900.html
> Sent from the Apache Flex Development mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [FlexJS] Failing build for simple example

piotrz
Thanks Josh! That is another reason to make the release happen!

Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Loading...