FlexSDK 4.16.0 installer errors

classic Classic list List threaded Threaded
21 messages Options
12
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

FlexSDK 4.16.0 installer errors

Justin Mclean
Administrator
Hi,

Not sure what we can do about it but I’m seeing a higher than usual error rates with the installer in google analytics, especially on windows

About 10% of all windows downloads are getting that 1000 error mention in the other thread , but we’re seeing a total error rate of about 60% for windows. On mac the total error rate is about 20%. (10-20% in the norm). For FlexJS the error rate is around 70% which is also a little higher than usual (it's normally in the 40-60% mark).

The windows errors more common that the 1000 one are the unknown  "info=Error” error and the 2032 error, which from memory is SSL related.

We're approaching 250 successful downloads which is some good news.

Thanks
Justin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: FlexSDK 4.16.0 installer errors

bschleicher
Hi,

I'm installing on Windows. Flex SDK 4.16.0 and AIR SDK 24 works with no problem.

Install Log of Flex SDK 4.16.0 and AIR SDK 25:

Installer version 3.2.0 (windows)
Using Locale: de_AT
Fetched the SDK download mirror URL from the CGI.
SDK version Apache Flex SDK 4.16.0
AIR version 25.0
Flash Player version 25.0
Creating Apache Flex home
Creating temporary directory
Downloading Apache Flex SDK from: http://mirror.klaus-uwe.me/apache/flex/4.16.0/binaries/apache-flex-sdk-4.16.0-bin.zip
Verifying Apache Flex SDK MD5 Signature
The Apache Flex SDK MD5 Signature of the downloaded files matches the reference. The file is valid.
Uncompressing: D:\Flex 4.16.0 - AIRSDK 25.0.0.X\temp\apache-flex-sdk-4.16.0-bin.zip
Finished uncompressing: D:\Flex 4.16.0 - AIRSDK 25.0.0.X\temp\apache-flex-sdk-4.16.0-bin.zip
Downloading Adobe AIR Runtime Kit for Windows from: http://airdownload.adobe.com/air/win/download/25.0//AdobeAIRSDK.zip
Validating download: D:\Flex 4.16.0 - AIRSDK 25.0.0.X/in/AdobeAIRSDK.zip
Error #1000

Regards,
Bernhard

-----Original Message-----
From: Justin Mclean [mailto:[hidden email]]
Sent: Freitag, 17. März 2017 06:55
To: [hidden email]
Subject: FlexSDK 4.16.0 installer errors

Hi,

Not sure what we can do about it but I’m seeing a higher than usual error rates with the installer in google analytics, especially on windows

About 10% of all windows downloads are getting that 1000 error mention in the other thread , but we’re seeing a total error rate of about 60% for windows. On mac the total error rate is about 20%. (10-20% in the norm). For FlexJS the error rate is around 70% which is also a little higher than usual (it's normally in the 40-60% mark).

The windows errors more common that the 1000 one are the unknown  "info=Error” error and the 2032 error, which from memory is SSL related.

We're approaching 250 successful downloads which is some good news.

Thanks
Justin

smime.p7s (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Justin Mclean
Administrator
Hi,

> Validating download: D:\Flex 4.16.0 - AIRSDK 25.0.0.X/in/AdobeAIRSDK.zip
> Error #1000

As mentioned in another thread AIR 25 zip is significantly larger in size and the the installer is running out of memory when trying to unzip it.

You might want to try closing a few open programs to free up some memory and trying again.

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: FlexSDK 4.16.0 installer errors

bschleicher
Hi,

At the time the error #1000 occurs I have 10 GB free memory. Maybe the
problem is that the installer runs as 32 bit process.

Regards,
Bernhard

-----Original Message-----
From: Justin Mclean [mailto:[hidden email]]
Sent: Freitag, 17. März 2017 07:52
To: [hidden email]
Subject: Re: FlexSDK 4.16.0 installer errors

Hi,

> Validating download: D:\Flex 4.16.0 - AIRSDK
> 25.0.0.X/in/AdobeAIRSDK.zip Error #1000

As mentioned in another thread AIR 25 zip is significantly larger in size
and the the installer is running out of memory when trying to unzip it.

You might want to try closing a few open programs to free up some memory and
trying again.

Thanks,
Justin

smime.p7s (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

hferreira
This post was updated on .
In reply to this post by Justin Mclean
Yes, I notice that from Flex 4.15 + AIR 23 to Flex 4.16 + AIR 25, it's almost the double size.
For me there is no problem and I have a 480 GB SSD.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Lydecker
In reply to this post by Justin Mclean
I've been having zero luck with Windows all day.

I've tried 7 different machines, which have varied from having 6Gb RAM to 32Gb! All of them have generated the #1000 error after validating AIR25.0

Hoping this isn't going to put off newcomers to Flex...

I tried on OSX and it downloaded fine, but my understanding is the download on OSX can't be copied to Windows as it strips the .exes out etc?

Sad face.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Jasen Martin
Hi all

Having same issue here, memory does not seem to be a problem I have 36 GM
ram and still get the following failed install

I too, managed to install on OSX (Seira) previously without issue.

Open to any ideas on workaround for windows...

Here is the log file:

Installer version 3.2.0 (windows)
Using Locale: en_AU
Fetched the SDK download mirror URL from the CGI.
SDK version Apache Flex SDK 4.16.0
AIR version 25.0
Flash Player version 25.0
Creating Apache Flex home
Creating temporary directory
Downloading Apache Flex SDK from:
http://apache.mirror.amaze.com.au/flex/4.16.0/binaries/apache-flex-sdk-4.16.0-bin.zip
Verifying Apache Flex SDK MD5 Signature
The Apache Flex SDK MD5 Signature of the downloaded files matches the
reference. The file is valid.
Unzipping: D:\FlexSDK_4.16_AIR_25\temp\apache-flex-sdk-4.16.0-bin.zip
Finished unzipping:
D:\FlexSDK_4.16_AIR_25\temp\apache-flex-sdk-4.16.0-bin.zip
Downloading Adobe AIR Runtime Kit for Windows from:
http://airdownload.adobe.com/air/win/download/25.0//AdobeAIRSDK.zip
Validating download: D:\FlexSDK_4.16_AIR_25/in/AdobeAIRSDK.zip
Error #1000


Thanks for any help
Jasen



On Thu, Mar 30, 2017 at 6:45 AM, Lydecker <[hidden email]> wrote:

> I've been having zero luck with Windows all day.
>
> I've tried 7 different machines, which have varied from having 6Gb RAM to
> 32Gb! All of them have generated the #1000 error after validating AIR25.0
>
> Hoping this isn't going to put off newcomers to Flex...
>
> I tried on OSX and it downloaded fine, but my understanding is the download
> on OSX can't be copied to Windows as it strips the .exes out etc?
>
> Sad face.
>
>
>
> --
> View this message in context: http://apache-flex-
> development.2333347.n4.nabble.com/FlexSDK-4-16-0-installer-
> errors-tp60542p60913.html
> Sent from the Apache Flex Development mailing list archive at Nabble.com.
>



--
------------------------------------------------------------
Jasen Martin
0424 984 955
------------------------------------------------------------
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Alex Harui
This is a known issue.  AIR 25 is so big, it blows up the memory of the
installer.

You can use Ant to do the install.  Download the binary, unzip it and run:
    ant -f installer.xml

HTH,
-Alex

On 4/14/17, 8:00 PM, "Jasen Martin" <[hidden email]> wrote:

>Hi all
>
>Having same issue here, memory does not seem to be a problem I have 36 GM
>ram and still get the following failed install
>
>I too, managed to install on OSX (Seira) previously without issue.
>
>Open to any ideas on workaround for windows...
>
>Here is the log file:
>
>Installer version 3.2.0 (windows)
>Using Locale: en_AU
>Fetched the SDK download mirror URL from the CGI.
>SDK version Apache Flex SDK 4.16.0
>AIR version 25.0
>Flash Player version 25.0
>Creating Apache Flex home
>Creating temporary directory
>Downloading Apache Flex SDK from:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache.mir
>ror.amaze.com.au%2Fflex%2F4.16.0%2Fbinaries%2Fapache-flex-sdk-4.16.0-bin.z
>ip&data=02%7C01%7C%7C3dabc11543084c21b50208d483ab9522%7Cfa7b1b5a7b34438794
>aed2c178decee1%7C0%7C0%7C636278220365820492&sdata=tl1aUGhSnLZmjgDZW77fuDdK
>3Fyo7tqukNkwrSgvVjE%3D&reserved=0
>Verifying Apache Flex SDK MD5 Signature
>The Apache Flex SDK MD5 Signature of the downloaded files matches the
>reference. The file is valid.
>Unzipping: D:\FlexSDK_4.16_AIR_25\temp\apache-flex-sdk-4.16.0-bin.zip
>Finished unzipping:
>D:\FlexSDK_4.16_AIR_25\temp\apache-flex-sdk-4.16.0-bin.zip
>Downloading Adobe AIR Runtime Kit for Windows from:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fairdownloa
>d.adobe.com%2Fair%2Fwin%2Fdownload%2F25.0%2F%2FAdobeAIRSDK.zip&data=02%7C0
>1%7C%7C3dabc11543084c21b50208d483ab9522%7Cfa7b1b5a7b34438794aed2c178decee1
>%7C0%7C0%7C636278220365820492&sdata=uRhA2JFc8keiX9NaUrA%2B6V9GzffZySg3KHBi
>KI3UELQ%3D&reserved=0
>Validating download: D:\FlexSDK_4.16_AIR_25/in/AdobeAIRSDK.zip
>Error #1000
>
>
>Thanks for any help
>Jasen
>
>
>
>On Thu, Mar 30, 2017 at 6:45 AM, Lydecker <[hidden email]> wrote:
>
>> I've been having zero luck with Windows all day.
>>
>> I've tried 7 different machines, which have varied from having 6Gb RAM
>>to
>> 32Gb! All of them have generated the #1000 error after validating
>>AIR25.0
>>
>> Hoping this isn't going to put off newcomers to Flex...
>>
>> I tried on OSX and it downloaded fine, but my understanding is the
>>download
>> on OSX can't be copied to Windows as it strips the .exes out etc?
>>
>> Sad face.
>>
>>
>>
>> --
>> View this message in context: http://apache-flex-
>> development.2333347.n4.nabble.com/FlexSDK-4-16-0-installer-
>> errors-tp60542p60913.html
>> Sent from the Apache Flex Development mailing list archive at
>>Nabble.com.
>>
>
>
>
>--
>------------------------------------------------------------
>Jasen Martin
>0424 984 955
>------------------------------------------------------------

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Lydecker
Hi Alex,

Quick question. If I use ant to do the install on Windows - it fails on line 453 in installer.xml ( <exec executable="rsync" dir="${FLEX_HOME}"> ) due to me not having rsync.exe on Windows. How do I go about getting rsync on Windows?

Thanks 

On 15 April 2017 at 06:20, Alex Harui [via Apache Flex Development] <[hidden email]> wrote:
This is a known issue.  AIR 25 is so big, it blows up the memory of the
installer.

You can use Ant to do the install.  Download the binary, unzip it and run:
    ant -f installer.xml

HTH,
-Alex

On 4/14/17, 8:00 PM, "Jasen Martin" <[hidden email]> wrote:

>Hi all
>
>Having same issue here, memory does not seem to be a problem I have 36 GM
>ram and still get the following failed install
>
>I too, managed to install on OSX (Seira) previously without issue.
>
>Open to any ideas on workaround for windows...
>
>Here is the log file:
>
>Installer version 3.2.0 (windows)
>Using Locale: en_AU
>Fetched the SDK download mirror URL from the CGI.
>SDK version Apache Flex SDK 4.16.0
>AIR version 25.0
>Flash Player version 25.0
>Creating Apache Flex home
>Creating temporary directory
>Downloading Apache Flex SDK from:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache.mir
>ror.amaze.com.au%2Fflex%2F4.16.0%2Fbinaries%2Fapache-flex-sdk-4.16.0-bin.z
>ip&data=02%7C01%7C%7C3dabc11543084c21b50208d483ab9522%7Cfa7b1b5a7b34438794
>aed2c178decee1%7C0%7C0%7C636278220365820492&sdata=tl1aUGhSnLZmjgDZW77fuDdK
>3Fyo7tqukNkwrSgvVjE%3D&reserved=0
>Verifying Apache Flex SDK MD5 Signature
>The Apache Flex SDK MD5 Signature of the downloaded files matches the
>reference. The file is valid.
>Unzipping: D:\FlexSDK_4.16_AIR_25\temp\apache-flex-sdk-4.16.0-bin.zip
>Finished unzipping:
>D:\FlexSDK_4.16_AIR_25\temp\apache-flex-sdk-4.16.0-bin.zip
>Downloading Adobe AIR Runtime Kit for Windows from:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fairdownloa
>d.adobe.com%2Fair%2Fwin%2Fdownload%2F25.0%2F%2FAdobeAIRSDK.zip&data=02%7C0
>1%7C%7C3dabc11543084c21b50208d483ab9522%7Cfa7b1b5a7b34438794aed2c178decee1
>%7C0%7C0%7C636278220365820492&sdata=uRhA2JFc8keiX9NaUrA%2B6V9GzffZySg3KHBi
>KI3UELQ%3D&reserved=0
>Validating download: D:\FlexSDK_4.16_AIR_25/in/AdobeAIRSDK.zip
>Error #1000
>
>
>Thanks for any help
>Jasen
>
>
>
>On Thu, Mar 30, 2017 at 6:45 AM, Lydecker <[hidden email]> wrote:
>
>> I've been having zero luck with Windows all day.
>>
>> I've tried 7 different machines, which have varied from having 6Gb RAM
>>to
>> 32Gb! All of them have generated the #1000 error after validating
>>AIR25.0
>>
>> Hoping this isn't going to put off newcomers to Flex...
>>
>> I tried on OSX and it downloaded fine, but my understanding is the
>>download
>> on OSX can't be copied to Windows as it strips the .exes out etc?
>>
>> Sad face.
>>
>>
>>
>> --
>> View this message in context: http://apache-flex-
>> development.2333347.n4.nabble.com/FlexSDK-4-16-0-installer-
>> errors-tp60542p60913.html
>> Sent from the Apache Flex Development mailing list archive at
>>Nabble.com.
>>
>
>
>
>--
>------------------------------------------------------------
>Jasen Martin
>0424 984 955
>------------------------------------------------------------



If you reply to this email, your message will be added to the discussion below:
http://apache-flex-development.2333347.n4.nabble.com/FlexSDK-4-16-0-installer-errors-tp60542p61123.html
To unsubscribe from FlexSDK 4.16.0 installer errors, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Alex Harui
On Windows, the script shouldn't go to line 453.  Please post the entire
console output.  What version of Windows are you using?

Thanks,
-Alex

On 4/15/17, 5:25 AM, "Lydecker" <[hidden email]> wrote:

>Hi Alex,
>
>Quick question. If I use ant to do the install on Windows - it fails on
>line 453 in installer.xml ( <exec executable="rsync" dir="${FLEX_HOME}"> )
>due to me not having rsync.exe on Windows. How do I go about getting rsync
>on Windows?
>
>Thanks
>
>On 15 April 2017 at 06:20, Alex Harui [via Apache Flex Development] <
>[hidden email]> wrote:
>
>> This is a known issue.  AIR 25 is so big, it blows up the memory of the
>> installer.
>>
>> You can use Ant to do the install.  Download the binary, unzip it and
>>run:
>>     ant -f installer.xml
>>
>> HTH,
>> -Alex
>>
>> On 4/14/17, 8:00 PM, "Jasen Martin" <[hidden email]
>> <http:///user/SendEmail.jtp?type=node&node=61123&i=0>> wrote:
>>
>> >Hi all
>> >
>> >Having same issue here, memory does not seem to be a problem I have 36
>>GM
>> >ram and still get the following failed install
>> >
>> >I too, managed to install on OSX (Seira) previously without issue.
>> >
>> >Open to any ideas on workaround for windows...
>> >
>> >Here is the log file:
>> >
>> >Installer version 3.2.0 (windows)
>> >Using Locale: en_AU
>> >Fetched the SDK download mirror URL from the CGI.
>> >SDK version Apache Flex SDK 4.16.0
>> >AIR version 25.0
>> >Flash Player version 25.0
>> >Creating Apache Flex home
>> >Creating temporary directory
>> >Downloading Apache Flex SDK from:
>> >https://na01.safelinks.protection.outlook.com/?url=
>> http%3A%2F%2Fapache.mir
>>
>>>ror.amaze.com.au%2Fflex%2F4.16.0%2Fbinaries%2Fapache-flex-sdk-4.16.0-bin
>>>.z
>>
>>
>>>ip&data=02%7C01%7C%7C3dabc11543084c21b50208d483ab9522%7Cfa7b1b5a7b344387
>>>94
>>
>>
>>>aed2c178decee1%7C0%7C0%7C636278220365820492&sdata=tl1aUGhSnLZmjgDZW77fuD
>>>dK
>>
>> >3Fyo7tqukNkwrSgvVjE%3D&reserved=0
>> >Verifying Apache Flex SDK MD5 Signature
>> >The Apache Flex SDK MD5 Signature of the downloaded files matches the
>> >reference. The file is valid.
>> >Unzipping: D:\FlexSDK_4.16_AIR_25\temp\apache-flex-sdk-4.16.0-bin.zip
>> >Finished unzipping:
>> >D:\FlexSDK_4.16_AIR_25\temp\apache-flex-sdk-4.16.0-bin.zip
>> >Downloading Adobe AIR Runtime Kit for Windows from:
>> >https://na01.safelinks.protection.outlook.com/?url=
>> http%3A%2F%2Fairdownloa
>>
>>>d.adobe.com%2Fair%2Fwin%2Fdownload%2F25.0%2F%2FAdobeAIRSDK.zip&data=02%7
>>>C0
>>
>>
>>>1%7C%7C3dabc11543084c21b50208d483ab9522%7Cfa7b1b5a7b34438794aed2c178dece
>>>e1
>>
>>
>>>%7C0%7C0%7C636278220365820492&sdata=uRhA2JFc8keiX9NaUrA%2B6V9GzffZySg3KH
>>>Bi
>>
>> >KI3UELQ%3D&reserved=0
>> >Validating download: D:\FlexSDK_4.16_AIR_25/in/AdobeAIRSDK.zip
>> >Error #1000
>> >
>> >
>> >Thanks for any help
>> >Jasen
>> >
>> >
>> >
>> >On Thu, Mar 30, 2017 at 6:45 AM, Lydecker <[hidden email]
>> <http:///user/SendEmail.jtp?type=node&node=61123&i=1>> wrote:
>> >
>> >> I've been having zero luck with Windows all day.
>> >>
>> >> I've tried 7 different machines, which have varied from having 6Gb
>>RAM
>> >>to
>> >> 32Gb! All of them have generated the #1000 error after validating
>> >>AIR25.0
>> >>
>> >> Hoping this isn't going to put off newcomers to Flex...
>> >>
>> >> I tried on OSX and it downloaded fine, but my understanding is the
>> >>download
>> >> on OSX can't be copied to Windows as it strips the .exes out etc?
>> >>
>> >> Sad face.
>> >>
>> >>
>> >>
>> >> --
>> >> View this message in context: http://apache-flex-
>> >> development.2333347.n4.nabble.com/FlexSDK-4-16-0-installer-
>> >> errors-tp60542p60913.html
>> >> Sent from the Apache Flex Development mailing list archive at
>> >>Nabble.com.
>> >>
>> >
>> >
>> >
>> >--
>> >------------------------------------------------------------
>> >Jasen Martin
>> >0424 984 955
>> >------------------------------------------------------------
>>
>>
>>
>> ------------------------------
>> If you reply to this email, your message will be added to the discussion
>> below:
>>
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-fl
>>ex-development.2333347.n4.nabble&data=02%7C01%7C%7C946d50ba33954d17a8c808
>>d48453f310%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C63627894347635634
>>0&sdata=URPi6GHwNXp1rxB5gOudFPvCouLgrnhCeotAYv2q2mI%3D&reserved=0.
>> com/FlexSDK-4-16-0-installer-errors-tp60542p61123.html
>> To unsubscribe from FlexSDK 4.16.0 installer errors, click here
>>
>><https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-f
>>lex-development.2333347.n4.nabble.com%2Ftemplate%2FNamlServlet.jtp%3Fmacr
>>o%3Dunsubscribe_by_code%26node%3D60542%26code%3DemFjaEB6aXp1bmV0d29yay5jb
>>y51a3w2MDU0MnwxOTEyNDM5NDkw&data=02%7C01%7C%7C946d50ba33954d17a8c808d4845
>>3f310%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636278943476366348&sda
>>ta=7vQZuU0WTTGez5LptqVdlA%2Fru%2FovRGXFT4Wodr6aX2g%3D&reserved=0>
>> .
>> NAML
>>
>><https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-f
>>lex-development.2333347.n4.nabble.com%2Ftemplate%2FNamlServlet.jtp%3Fmacr
>>o%3Dmacro_viewer%26id%3Dinstant_html%2521nabble%253Aemail.naml%26base%3Dn
>>abble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNames
>>pace-nabble.view.web.template.NodeNamespace%26breadcrumbs%3Dnotify_subscr
>>ibers%2521nabble%253Aemail.naml-instant_emails%2521nabble%253Aemail.naml-
>>send_instant_email%2521nabble%253Aemail.naml&data=02%7C01%7C%7C946d50ba33
>>954d17a8c808d48453f310%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C63627
>>8943476366348&sdata=lziHSnnk0PyDhrbeH10G2dYDRDagw3X3htyo7W6u1uc%3D&reserv
>>ed=0>
>>
>
>
>
>
>--
>View this message in context:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-fle
>x-development.2333347.n4.nabble.com%2FFlexSDK-4-16-0-installer-errors-tp60
>542p61124.html&data=02%7C01%7C%7C946d50ba33954d17a8c808d48453f310%7Cfa7b1b
>5a7b34438794aed2c178decee1%7C0%7C0%7C636278943476366348&sdata=wBhJr3dVKN9x
>WkpnBZrTc%2Fd6sFU87hl6YaK%2FR07fqE8%3D&reserved=0
>Sent from the Apache Flex Development mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Lydecker
Hi Alex,

Thanks for taking the time to look at this. I'm using Windows 10 64bit.

As requested, the console output is below.

I am following the guidance here: https://cwiki.apache.org/confluence/display/FLEX/Installation+help






D:\f16>ant -f installer.xml -Dair.sdk.version=25.0
Buildfile: D:\f16\installer.xml
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

get-data:
      [get] Getting: http://flex.apache.org/installer/sdk-installer-config-4.0.xml?ts=201704161743
      [get] To: D:\f16\sdk-installer-config-4.0.xml

get-air-md5-data:

get-flash-md5-data:

get-md5-data:

check-binary:

ask-air:
    [input] Apache Flex SDK uses the Adobe AIR SDK to build Adobe AIR applications.
    [input] The Adobe AIR SDK is subject to and governed by the
    [input] Adobe AIR SDK License Agreement specified here:
    [input] http://www.adobe.com/products/air/sdk-eula.html.
    [input] This license is not compatible with the Apache v2 license.
    [input] Do you want to download and install the Adobe AIR SDK? (y, [n])
y

ask-flash:
    [input] Apache Flex SDK uses the Adobe Flash Player's playerglobal.swc to build Adobe Flash applications.
    [input]
    [input] The playerglobal.swc file is subject to and governed by the
    [input] Adobe Flex SDK License Agreement specified here:
    [input] http://www.adobe.com/products/eulas/pdfs/adobe_flex_software_development_kit-combined-20110916_0930.pdf,
    [input] By downloading, modifying, distributing, using and/or accessing the playerglobal.swc file
    [input] you agree to the terms and conditions of the applicable end user license agreement.
    [input]
    [input] In addition to the Adobe license terms, you also agree to be bound by the third-party terms specified here:
    [input] http://www.adobe.com/products/eula/third_party/.
    [input] Adobe recommends that you review these third-party terms.
    [input]
    [input] This license is not compatible with the Apache v2 license.
    [input] Do you want to download and install the playerglobal.swc? (y, [n])
y

ask-swfobject:

ask-ofl:

ask-adobe-osmf:

ask-adobe-fontswf:
    [input] Apache Flex can optionally integrate with Adobe's embedded font support.
    [input] This feature requires a few font jars from the Adobe Flex SDK.
    [input] The Adobe SDK license agreement for Adobe Flex 4.6 applies to these jars.
    [input] This license is not compatible with the Apache v2 license.
    [input]
    [input] Adobe Flex SDK License Agreement:
    [input]
    [input] All files contained in this Adobe Flex SDK download are subject to and governed by the
    [input] Adobe Flex SDK License Agreement specified here:
    [input] http://www.adobe.com/products/eulas/pdfs/adobe_flex_software_development_kit-combined-20110916_0930.pdf,
    [input] By downloading, modifying, distributing, using and/or accessing any files in this Adobe Flex SDK,
    [input] you agree to the terms and conditions of the applicable end user license agreement.
    [input]
    [input] In addition to the Adobe license terms, you also agree to be bound by the third-party terms specified here:
    [input] http://www.adobe.com/products/eula/third_party/.
    [input] Adobe recommends that you review these third-party terms.
    [input]
    [input] Do you want to install this jar from the Adobe Flex SDK? (y, [n])
y

ask-licenses:

air-check:

air-download:
    [mkdir] Created dir: D:\f16\in
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

air-get-check:

air-get:
     [echo] Downloading Adobe AIR Runtime Kit for Windows from:  http://airdownload.adobe.com/air/win/download/25.0//AdobeAIRSDK.zip
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

download_air:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

download_air_with_md5:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

check-cache:

download_using_get:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

get-if-not-cached:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

check-params:

get-with-no-params:
      [get] Getting: http://airdownload.adobe.com/air/win/download/25.0//AdobeAIRSDK.zip?ts=201704161743
      [get] To: D:\f16\in\AdobeAIRSDK.zip
      [get] http://airdownload.adobe.com/air/win/download/25.0//AdobeAIRSDK.zip?ts=201704161743 permanently moved to https://airdownload.adobe.com/air/win/download/25.0/AdobeAIRSDK.zip?ts=201704161743
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

check-params:

get-with-params:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

check-params:

get-local:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

check-sum:
     [echo] Validating download: D:\f16/in/AdobeAIRSDK.zip
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

put-in-cache:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

copy-if-cached:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

air-setup-win:
    [unzip] Expanding: D:\f16\in\AdobeAIRSDK.zip into D:\f16\in\airsdk
     [echo] Finished uncompressing:  D:\f16/in/AdobeAIRSDK.zip
     [copy] Copying 666 files to D:\f16
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\f16\en_US.properties

unzipOrMountDMG:
     [move] Moving 1 file to D:\f16\in\airsdk
     [echo] Should unzip: ${shouldUnzip}

unzipAIRSDK:

mountAIRSDK:
     [echo] Mounting dmg

copyFromMount:
     [echo] Copying AIR SDK from mounted volume

BUILD FAILED
D:\f16\installer.xml:354: The following error occurred while executing this line:
D:\f16\installer.xml:453: Execute failed: java.io.IOException: Cannot run program "rsync" (in directory "D:\f16"): CreateProcess error=2, The system cannot find the file specified
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
        at java.lang.Runtime.exec(Runtime.java:620)
        at org.apache.tools.ant.taskdefs.launcher.Java13CommandLauncher.exec(Java13CommandLauncher.java:58)
        at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:426)
        at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:440)
        at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:629)
        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:670)
        at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:496)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:293)
        at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:435)
        at org.apache.tools.ant.Target.performTasks(Target.java:456)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1405)
        at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1260)
        at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:441)
        at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:293)
        at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
        at org.apache.tools.ant.Task.perform(Task.java:348)
        at org.apache.tools.ant.Target.execute(Target.java:435)
        at org.apache.tools.ant.Target.performTasks(Target.java:456)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1405)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1376)
        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1260)
        at org.apache.tools.ant.Main.runBuild(Main.java:857)
        at org.apache.tools.ant.Main.startAnt(Main.java:236)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:287)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:113)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
        at java.lang.ProcessImpl.create(Native Method)
        at java.lang.ProcessImpl.<init>(ProcessImpl.java:386)
        at java.lang.ProcessImpl.start(ProcessImpl.java:137)
        at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
        ... 36 more

Total time: 1 minute 20 seconds
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

danielmcquillen
Hi All,

Attempting ant install like others. Probs silly question but if I'm only targeting captive runtime, do I need to follow steps #4 and #5 in the readme and install the Flash Player content debugger and playerglobal.swc or can I safely ignore those?

Alternatively, is the AIR installer going to be back online soon? Now that it's gone I'm reminded of how helpful it was.

Thanks for any thoughts!

Daniel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Alex Harui
In reply to this post by Lydecker
Hi,

I guess we never tested the Ant install on Windows.  The console output
showed that there is a bug in the script.
I guess the simplest fix is to edit installer.xml and remove this line
(which is line 354 for me):

        <antcall target="air-setup-mac" />

Thanks,

-Alex


On 4/16/17, 9:38 AM, "Lydecker" <[hidden email]> wrote:

>Hi Alex,
>
>Thanks for taking the time to look at this. I'm using Windows 10 64bit.
>
>As requested, the console output is below.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Alex Harui
In reply to this post by danielmcquillen


On 4/16/17, 8:20 PM, "danielmcquillen" <[hidden email]>
wrote:

>Hi All,
>
>Attempting ant install like others. Probs silly question but if I'm only
>targeting captive runtime, do I need to follow steps #4 and #5 in the
>readme
>and install the Flash Player content debugger and playerglobal.swc or can
>I
>safely ignore those?

Well, technically, you don't need those, but I think Flash Builder might
think the folder isn't a Flex SDK if you don't have those files.  Not sure
if other IDEs are expecting those files as well.

>
>Alternatively, is the AIR installer going to be back online soon? Now that
>it's gone I'm reminded of how helpful it was.

The problem is that we either need to rewrite the MD5 buffering, or switch
to a 64-bit Windows EXE, but there is no way to generate an "installer for
the installer" in 64-bit Windows.  Other creative ideas are welcome, as
are volunteers to make the required changes.

I agree we need to do something to get the Installer to work, but I don't
think we've achieved consensus on what to do.

Thanks,
-Alex

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Lydecker
In reply to this post by Alex Harui
Hi Alex,

Thanks for the advice - still getting an error with windows - seems to be with OSFM download - which is weird as the mirror it fails to grab the file from I can get when browsing to the URL directly. Here is the console output - any pointers?

Thanks

D:\F162>ant -f installer.xml -Dair.sdk.version=25.0
Buildfile: D:\F162\installer.xml
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

get-data:
      [get] Getting: http://flex.apache.org/installer/sdk-installer-config-4.0.xml?ts=201704171329
      [get] To: D:\F162\sdk-installer-config-4.0.xml

get-air-md5-data:

get-flash-md5-data:

get-md5-data:

check-binary:

ask-air:
    [input] Apache Flex SDK uses the Adobe AIR SDK to build Adobe AIR applications.
    [input] The Adobe AIR SDK is subject to and governed by the
    [input] Adobe AIR SDK License Agreement specified here:
    [input] http://www.adobe.com/products/air/sdk-eula.html.
    [input] This license is not compatible with the Apache v2 license.
    [input] Do you want to download and install the Adobe AIR SDK? (y, [n])
y

ask-flash:
    [input] Apache Flex SDK uses the Adobe Flash Player's playerglobal.swc to build Adobe Flash applications.
    [input]
    [input] The playerglobal.swc file is subject to and governed by the
    [input] Adobe Flex SDK License Agreement specified here:
    [input] http://www.adobe.com/products/eulas/pdfs/adobe_flex_software_development_kit-combined-20110916_0930.pdf,
    [input] By downloading, modifying, distributing, using and/or accessing the playerglobal.swc file
    [input] you agree to the terms and conditions of the applicable end user license agreement.
    [input]
    [input] In addition to the Adobe license terms, you also agree to be bound by the third-party terms specified here:
    [input] http://www.adobe.com/products/eula/third_party/.
    [input] Adobe recommends that you review these third-party terms.
    [input]
    [input] This license is not compatible with the Apache v2 license.
    [input] Do you want to download and install the playerglobal.swc? (y, [n])
y

ask-swfobject:

ask-ofl:

ask-adobe-osmf:

ask-adobe-fontswf:
    [input] Apache Flex can optionally integrate with Adobe's embedded font support.
    [input] This feature requires a few font jars from the Adobe Flex SDK.
    [input] The Adobe SDK license agreement for Adobe Flex 4.6 applies to these jars.
    [input] This license is not compatible with the Apache v2 license.
    [input]
    [input] Adobe Flex SDK License Agreement:
    [input]
    [input] All files contained in this Adobe Flex SDK download are subject to and governed by the
    [input] Adobe Flex SDK License Agreement specified here:
    [input] http://www.adobe.com/products/eulas/pdfs/adobe_flex_software_development_kit-combined-20110916_0930.pdf,
    [input] By downloading, modifying, distributing, using and/or accessing any files in this Adobe Flex SDK,
    [input] you agree to the terms and conditions of the applicable end user license agreement.
    [input]
    [input] In addition to the Adobe license terms, you also agree to be bound by the third-party terms specified here:
    [input] http://www.adobe.com/products/eula/third_party/.
    [input] Adobe recommends that you review these third-party terms.
    [input]
    [input] Do you want to install this jar from the Adobe Flex SDK? (y, [n])
y

ask-licenses:

air-check:

air-download:
    [mkdir] Created dir: D:\F162\in
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

air-get-check:

air-get:
     [echo] Downloading Adobe AIR Runtime Kit for Windows from:  http://airdownload.adobe.com/air/win/download/25.0//AdobeAIRSDK.zip
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

download_air:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

download_air_with_md5:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-cache:

download_using_get:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

get-if-not-cached:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-with-no-params:
      [get] Getting: http://airdownload.adobe.com/air/win/download/25.0//AdobeAIRSDK.zip?ts=201704171329
      [get] To: D:\F162\in\AdobeAIRSDK.zip
      [get] http://airdownload.adobe.com/air/win/download/25.0//AdobeAIRSDK.zip?ts=201704171329 permanently moved to https://airdownload.adobe.com/air/win/download/25.0/AdobeAIRSDK.zip?ts=201704171329
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-with-params:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-local:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-sum:
     [echo] Validating download: D:\F162/in/AdobeAIRSDK.zip
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

put-in-cache:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

copy-if-cached:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

air-setup-win:
    [unzip] Expanding: D:\F162\in\AdobeAIRSDK.zip into D:\F162\in\airsdk
     [echo] Finished uncompressing:  D:\F162/in/AdobeAIRSDK.zip
     [copy] Copying 666 files to D:\F162

flash-check:

flash-download:
    [mkdir] Created dir: D:\F162\frameworks\libs\player\23.0
     [echo] Installing Adobe Flash Player playerglobal.swc from:  http://fpdownload.macromedia.com/get/flashplayer/updaters/23//playerglobal23_0.swc
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

download_flash:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

download_flash_with_md5:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-cache:

download_using_get:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

get-if-not-cached:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-with-no-params:
      [get] Getting: http://fpdownload.macromedia.com/get/flashplayer/updaters/23//playerglobal23_0.swc?ts=201704171329
      [get] To: D:\F162\frameworks\libs\player\23.0\playerglobal.swc
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-with-params:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-local:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-sum:
     [echo] Validating download: D:\F162/frameworks/libs/player/23.0/playerglobal.swc
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

put-in-cache:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

copy-if-cached:

swfobject-check:

swfobject-download:
   [delete] Deleting: D:\F162\swfobject.properties
     [echo] Downloading 2.2.zip from: https://github.com/swfobject/swfobject/archive
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-cache:

download_using_get:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

get-if-not-cached:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-with-no-params:
      [get] Getting: https://github.com/swfobject/swfobject/archive/2.2.zip?ts=201704171329
      [get] To: D:\F162\in\swfobject_2_2.zip
      [get] https://github.com/swfobject/swfobject/archive/2.2.zip?ts=201704171329 moved to https://codeload.github.com/swfobject/swfobject/zip/2.2
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-with-params:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-local:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-sum:
     [echo] Validating download: D:\F162/in/swfobject_2_2.zip
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

put-in-cache:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

copy-if-cached:
     [echo] Download complete
    [mkdir] Created dir: D:\F162\in\swfobject
    [unzip] Expanding: D:\F162\in\swfobject_2_2.zip into D:\F162\in\swfobject
     [copy] Copying 1 file to D:\F162\templates\swfobject
     [copy] Copying 1 file to D:\F162\templates\swfobject
    [mkdir] Created dir: D:\F162\frameworks\javascript\fabridge\samples\fabridge\swfobject
     [copy] Copying 1 file to D:\F162\frameworks\javascript\fabridge\samples\fabridge\swfobject

osmf-check:

osmf-download:
   [delete] Deleting: D:\F162\osmf.properties
     [echo] Downloading OSMF2_0.swc?format=raw from: http://sourceforge.net/adobe/flexsdk/code/HEAD/tree/trunk/frameworks/libs
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-cache:

download_using_get:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

get-if-not-cached:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-with-no-params:
      [get] Getting: http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To: D:\F162\en_US.properties

check-params:

get-with-params:
      [get] Getting: http://sourceforge.net/adobe/flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw&ts=201704171329
      [get] To: D:\F162\frameworks\libs\osmf.swc
      [get] http://sourceforge.net/adobe/flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw&ts=201704171329 moved to https://sourceforge.net/adobe/flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw&ts=201704171329
      [get] Error getting http://sourceforge.net/adobe/flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw&ts=201704171329 to D:\F162\frameworks\libs\osmf.swc

BUILD FAILED
D:\F162\installer.xml:705: The following error occurred while executing this line:
D:\F162\installer.xml:916: The following error occurred while executing this line:
D:\F162\installer.xml:924: The following error occurred while executing this line:
D:\F162\installer.xml:966: javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure
        at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
        at sun.security.ssl.Alerts.getSSLException(Alerts.java:154)
        at sun.security.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:2023)
        at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1125)
        at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1375)
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403)
        at sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387)
        at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559)
        at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
        at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(HttpsURLConnectionImpl.java:153)
        at org.apache.tools.ant.taskdefs.Get$GetThread.openConnection(Get.java:737)
        at org.apache.tools.ant.taskdefs.Get$GetThread.openConnection(Get.java:757)
        at org.apache.tools.ant.taskdefs.Get$GetThread.get(Get.java:650)
        at org.apache.tools.ant.taskdefs.Get$GetThread.run(Get.java:640)

Total time: 1 minute 26 seconds
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Alex Harui
That smells like the JCE problem.


On 4/17/17, 5:25 AM, "Lydecker" <[hidden email]> wrote:

>
>osmf-download:
>   [delete] Deleting: D:\F162\osmf.properties
>     [echo] Downloading OSMF2_0.swc?format=raw from:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourceforg
>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs&d
>ata=02%7C01%7C%7C6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2
>c178decee1%7C0%7C0%7C636280405458087777&sdata=EFkG64F%2FmGfU3rXXlOj8lXmRr%
>2FH9xXUew6n37JqivLY%3D&reserved=0
>      [get] Getting:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apach
>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7C
>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C
>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbux
>oU%3D&reserved=0
>      [get] To: D:\F162\en_US.properties
>
>check-cache:
>
>download_using_get:
>      [get] Getting:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apach
>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7C
>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C
>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbux
>oU%3D&reserved=0
>      [get] To: D:\F162\en_US.properties
>
>get-if-not-cached:
>      [get] Getting:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apach
>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7C
>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C
>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbux
>oU%3D&reserved=0
>      [get] To: D:\F162\en_US.properties
>
>check-params:
>
>get-with-no-params:
>      [get] Getting:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apach
>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7C
>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C
>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbux
>oU%3D&reserved=0
>      [get] To: D:\F162\en_US.properties
>
>check-params:
>
>get-with-params:
>      [get] Getting:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourceforg
>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%2
>FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b29e
>ca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C6362
>80405458087777&sdata=H2nijzFgeiJqv5iWTY5Jx1FUo6xewhFpLxGu0cx4ETY%3D&reserv
>ed=0
>      [get] To: D:\F162\frameworks\libs\osmf.swc
>      [get]
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourceforg
>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%2
>FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b29e
>ca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C6362
>80405458087777&sdata=H2nijzFgeiJqv5iWTY5Jx1FUo6xewhFpLxGu0cx4ETY%3D&reserv
>ed=0
>moved to
>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fsourcefor
>ge.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%
>2FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b29
>eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636
>280405458087777&sdata=Bv9ni9QLntVw%2BnfaKn1zjx2guAmy2mUYufWx4mTiwL0%3D&res
>erved=0
>      [get] Error getting
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourceforg
>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%2
>FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b29e
>ca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C6362
>80405458087777&sdata=H2nijzFgeiJqv5iWTY5Jx1FUo6xewhFpLxGu0cx4ETY%3D&reserv
>ed=0
>to D:\F162\frameworks\libs\osmf.swc
>
>BUILD FAILED
>D:\F162\installer.xml:705: The following error occurred while executing
>this
>line:
>D:\F162\installer.xml:916: The following error occurred while executing
>this
>line:
>D:\F162\installer.xml:924: The following error occurred while executing
>this
>line:
>D:\F162\installer.xml:966: javax.net.ssl.SSLHandshakeException: Received
>fatal alert: handshake_failure
>        at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
>        at sun.security.ssl.Alerts.getSSLException(Alerts.java:154)
>        at
>sun.security.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:2023)
>        at
>sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1125)
>        at
>sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:
>1375)
>        at
>sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403)
>        at
>sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387)
>        at
>sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559)
>        at
>sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Abst
>ractDelegateHttpsURLConnection.java:185)
>        at
>sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(HttpsURLConnecti
>onImpl.java:153)
>        at
>org.apache.tools.ant.taskdefs.Get$GetThread.openConnection(Get.java:737)
>        at
>org.apache.tools.ant.taskdefs.Get$GetThread.openConnection(Get.java:757)
>        at org.apache.tools.ant.taskdefs.Get$GetThread.get(Get.java:650)
>        at org.apache.tools.ant.taskdefs.Get$GetThread.run(Get.java:640)
>
>Total time: 1 minute 26 seconds
>
>
>
>--
>View this message in context:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-fle
>x-development.2333347.n4.nabble.com%2FFlexSDK-4-16-0-installer-errors-tp60
>542p61151.html&data=02%7C01%7C%7C6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b
>5a7b34438794aed2c178decee1%7C0%7C0%7C636280405458087777&sdata=RipsSy4WP0JR
>Gwexmz3NBv9orKjVnGnQ9T5RZ%2BexOFU%3D&reserved=0
>Sent from the Apache Flex Development mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Alex Harui
Here are some links:

http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-21331
66.html

http://www.oracle.com/technetwork/java/javase/downloads/jce-7-download-4321
24.html

Just moving to the latest Java 8 should also fix it.

HTH,

-ALex

On 4/17/17, 9:54 AM, "Alex Harui" <[hidden email]> wrote:

>That smells like the JCE problem.
>
>
>On 4/17/17, 5:25 AM, "Lydecker" <[hidden email]> wrote:
>>
>>osmf-download:
>>   [delete] Deleting: D:\F162\osmf.properties
>>     [echo] Downloading OSMF2_0.swc?format=raw from:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourcefor
>>g
>>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs&
>>d
>>ata=02%7C01%7C%7C6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed
>>2
>>c178decee1%7C0%7C0%7C636280405458087777&sdata=EFkG64F%2FmGfU3rXXlOj8lXmRr
>>%
>>2FH9xXUew6n37JqivLY%3D&reserved=0
>>      [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apac
>>h
>>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7
>>C
>>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7
>>C
>>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbu
>>x
>>oU%3D&reserved=0
>>      [get] To: D:\F162\en_US.properties
>>
>>check-cache:
>>
>>download_using_get:
>>      [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apac
>>h
>>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7
>>C
>>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7
>>C
>>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbu
>>x
>>oU%3D&reserved=0
>>      [get] To: D:\F162\en_US.properties
>>
>>get-if-not-cached:
>>      [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apac
>>h
>>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7
>>C
>>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7
>>C
>>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbu
>>x
>>oU%3D&reserved=0
>>      [get] To: D:\F162\en_US.properties
>>
>>check-params:
>>
>>get-with-no-params:
>>      [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apac
>>h
>>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7
>>C
>>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7
>>C
>>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbu
>>x
>>oU%3D&reserved=0
>>      [get] To: D:\F162\en_US.properties
>>
>>check-params:
>>
>>get-with-params:
>>      [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourcefor
>>g
>>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%
>>2
>>FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b29
>>e
>>ca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636
>>2
>>80405458087777&sdata=H2nijzFgeiJqv5iWTY5Jx1FUo6xewhFpLxGu0cx4ETY%3D&reser
>>v
>>ed=0
>>      [get] To: D:\F162\frameworks\libs\osmf.swc
>>      [get]
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourcefor
>>g
>>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%
>>2
>>FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b29
>>e
>>ca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636
>>2
>>80405458087777&sdata=H2nijzFgeiJqv5iWTY5Jx1FUo6xewhFpLxGu0cx4ETY%3D&reser
>>v
>>ed=0
>>moved to
>>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fsourcefo
>>r
>>ge.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs
>>%
>>2FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b2
>>9
>>eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C63
>>6
>>280405458087777&sdata=Bv9ni9QLntVw%2BnfaKn1zjx2guAmy2mUYufWx4mTiwL0%3D&re
>>s
>>erved=0
>>      [get] Error getting
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourcefor
>>g
>>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%
>>2
>>FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b29
>>e
>>ca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636
>>2
>>80405458087777&sdata=H2nijzFgeiJqv5iWTY5Jx1FUo6xewhFpLxGu0cx4ETY%3D&reser
>>v
>>ed=0
>>to D:\F162\frameworks\libs\osmf.swc
>>
>>BUILD FAILED
>>D:\F162\installer.xml:705: The following error occurred while executing
>>this
>>line:
>>D:\F162\installer.xml:916: The following error occurred while executing
>>this
>>line:
>>D:\F162\installer.xml:924: The following error occurred while executing
>>this
>>line:
>>D:\F162\installer.xml:966: javax.net.ssl.SSLHandshakeException: Received
>>fatal alert: handshake_failure
>>        at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
>>        at sun.security.ssl.Alerts.getSSLException(Alerts.java:154)
>>        at
>>sun.security.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:2023)
>>        at
>>sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1125)
>>        at
>>sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java
>>:
>>1375)
>>        at
>>sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403)
>>        at
>>sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387)
>>        at
>>sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559)
>>        at
>>sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Abs
>>t
>>ractDelegateHttpsURLConnection.java:185)
>>        at
>>sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(HttpsURLConnect
>>i
>>onImpl.java:153)
>>        at
>>org.apache.tools.ant.taskdefs.Get$GetThread.openConnection(Get.java:737)
>>        at
>>org.apache.tools.ant.taskdefs.Get$GetThread.openConnection(Get.java:757)
>>        at org.apache.tools.ant.taskdefs.Get$GetThread.get(Get.java:650)
>>        at org.apache.tools.ant.taskdefs.Get$GetThread.run(Get.java:640)
>>
>>Total time: 1 minute 26 seconds
>>
>>
>>
>>--
>>View this message in context:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-fl
>>e
>>x-development.2333347.n4.nabble.com%2FFlexSDK-4-16-0-installer-errors-tp6
>>0
>>542p61151.html&data=02%7C01%7C%7C6540b29eca594b7c3c5108d485a8582a%7Cfa7b1
>>b
>>5a7b34438794aed2c178decee1%7C0%7C0%7C636280405458087777&sdata=RipsSy4WP0J
>>R
>>Gwexmz3NBv9orKjVnGnQ9T5RZ%2BexOFU%3D&reserved=0
>>Sent from the Apache Flex Development mailing list archive at Nabble.com.
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Lydecker
That seems to have done the trick - thanks!

Quick question, should my /frameworks/libs/player directory not have a '25.0' folder in it following the ant install (given I prompted for version 25 and said yes to downloading the playerglobal.swc file?). I only have a 23.0 file in my  /frameworks/libs/player directory following the script successfully completing.... The console output even says it was grabbing 23.0 not 25.0 - is this just the installer.xml file that needs updating?

On 17 April 2017 at 17:46, Alex Harui [via Apache Flex Development] <[hidden email]> wrote:
Here are some links:

http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-21331
66.html

http://www.oracle.com/technetwork/java/javase/downloads/jce-7-download-4321
24.html

Just moving to the latest Java 8 should also fix it.

HTH,

-ALex

On 4/17/17, 9:54 AM, "Alex Harui" <[hidden email]> wrote:

>That smells like the JCE problem.
>
>
>On 4/17/17, 5:25 AM, "Lydecker" <[hidden email]> wrote:
>>
>>osmf-download:
>>   [delete] Deleting: D:\F162\osmf.properties
>>     [echo] Downloading OSMF2_0.swc?format=raw from:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourcefor
>>g
>>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs&
>>d
>>ata=02%7C01%7C%7C6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed
>>2
>>c178decee1%7C0%7C0%7C636280405458087777&sdata=EFkG64F%2FmGfU3rXXlOj8lXmRr
>>%
>>2FH9xXUew6n37JqivLY%3D&reserved=0
>>      [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apac
>>h
>>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7
>>C
>>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7
>>C
>>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbu
>>x
>>oU%3D&reserved=0
>>      [get] To: D:\F162\en_US.properties
>>
>>check-cache:
>>
>>download_using_get:
>>      [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apac
>>h
>>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7
>>C
>>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7
>>C
>>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbu
>>x
>>oU%3D&reserved=0
>>      [get] To: D:\F162\en_US.properties
>>
>>get-if-not-cached:
>>      [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apac
>>h
>>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7
>>C
>>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7
>>C
>>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbu
>>x
>>oU%3D&reserved=0
>>      [get] To: D:\F162\en_US.properties
>>
>>check-params:
>>
>>get-with-no-params:
>>      [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apac
>>h
>>e.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7C%7
>>C
>>6540b29eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7
>>C
>>0%7C636280405458087777&sdata=PNdlZRlt6%2B%2B2HPbBBCnKwdutUHNTdINM8EQZEPbu
>>x
>>oU%3D&reserved=0
>>      [get] To: D:\F162\en_US.properties
>>
>>check-params:
>>
>>get-with-params:
>>      [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourcefor
>>g
>>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%
>>2
>>FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b29
>>e
>>ca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636
>>2
>>80405458087777&sdata=H2nijzFgeiJqv5iWTY5Jx1FUo6xewhFpLxGu0cx4ETY%3D&reser
>>v
>>ed=0
>>      [get] To: D:\F162\frameworks\libs\osmf.swc
>>      [get]
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourcefor
>>g
>>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%
>>2
>>FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b29
>>e
>>ca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636
>>2
>>80405458087777&sdata=H2nijzFgeiJqv5iWTY5Jx1FUo6xewhFpLxGu0cx4ETY%3D&reser
>>v
>>ed=0
>>moved to
>>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fsourcefo
>>r
>>ge.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs
>>%
>>2FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b2
>>9
>>eca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C63
>>6
>>280405458087777&sdata=Bv9ni9QLntVw%2BnfaKn1zjx2guAmy2mUYufWx4mTiwL0%3D&re
>>s
>>erved=0
>>      [get] Error getting
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fsourcefor
>>g
>>e.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%
>>2
>>FOSMF2_0.swc%3Fformat%3Draw%26ts%3D201704171329&data=02%7C01%7C%7C6540b29
>>e
>>ca594b7c3c5108d485a8582a%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636
>>2
>>80405458087777&sdata=H2nijzFgeiJqv5iWTY5Jx1FUo6xewhFpLxGu0cx4ETY%3D&reser
>>v
>>ed=0
>>to D:\F162\frameworks\libs\osmf.swc
>>
>>BUILD FAILED
>>D:\F162\installer.xml:705: The following error occurred while executing
>>this
>>line:
>>D:\F162\installer.xml:916: The following error occurred while executing
>>this
>>line:
>>D:\F162\installer.xml:924: The following error occurred while executing
>>this
>>line:
>>D:\F162\installer.xml:966: javax.net.ssl.SSLHandshakeException: Received
>>fatal alert: handshake_failure
>>        at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
>>        at sun.security.ssl.Alerts.getSSLException(Alerts.java:154)
>>        at
>>sun.security.ssl.SSLSocketImpl.recvAlert(SSLSocketImpl.java:2023)
>>        at
>>sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:1125)
>>        at
>>sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java
>>:
>>1375)
>>        at
>>sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1403)
>>        at
>>sun.security.ssl.SSLSocketImpl.startHandshake(SSLSocketImpl.java:1387)
>>        at
>>sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:559)
>>        at
>>sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Abs
>>t
>>ractDelegateHttpsURLConnection.java:185)
>>        at
>>sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(HttpsURLConnect
>>i
>>onImpl.java:153)
>>        at
>>org.apache.tools.ant.taskdefs.Get$GetThread.openConnection(Get.java:737)
>>        at
>>org.apache.tools.ant.taskdefs.Get$GetThread.openConnection(Get.java:757)
>>        at org.apache.tools.ant.taskdefs.Get$GetThread.get(Get.java:650)
>>        at org.apache.tools.ant.taskdefs.Get$GetThread.run(Get.java:640)
>>
>>Total time: 1 minute 26 seconds
>>
>>
>>
>>--
>>View this message in context:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-fl
>>e
>>x-development.2333347.n4.nabble.com%2FFlexSDK-4-16-0-installer-errors-tp6
>>0
>>542p61151.html&data=02%7C01%7C%7C6540b29eca594b7c3c5108d485a8582a%7Cfa7b1
>>b
>>5a7b34438794aed2c178decee1%7C0%7C0%7C636280405458087777&sdata=RipsSy4WP0J
>>R
>>Gwexmz3NBv9orKjVnGnQ9T5RZ%2BexOFU%3D&reserved=0
>>Sent from the Apache Flex Development mailing list archive at Nabble.com.
>



If you reply to this email, your message will be added to the discussion below:
http://apache-flex-development.2333347.n4.nabble.com/FlexSDK-4-16-0-installer-errors-tp60542p61157.html
To unsubscribe from FlexSDK 4.16.0 installer errors, click here.
NAML

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

Alex Harui


On 4/17/17, 1:44 PM, "Lydecker" <[hidden email]> wrote:

>That seems to have done the trick - thanks!
>
>Quick question, should my /frameworks/libs/player directory not have a
>'25.0' folder in it following the ant install (given I prompted for
>version
>25 and said yes to downloading the playerglobal.swc file?). I only have a
>23.0 file in my  /frameworks/libs/player directory following the script
>successfully completing.... The console output even says it was grabbing
>23.0 not 25.0 - is this just the installer.xml file that needs updating?

Hmm.  I don't think there is a prompt for the playerglobal version, just a
prompt to accept the licensing terms.

I think you actually installed playerglobal version 23.  I forgot to
mention that to get playerglobal version 25 you have to use:

  ant -f installer.xml -Dflash.sdk.version=25.0 -Dair.sdk.version=25.0

HTH,
-Alex

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FlexSDK 4.16.0 installer errors

danielmcquillen
In reply to this post by Lydecker
Hi @Lydecker,

Did you not get a

   Target "25.0" does not exist in the project "sdk_ide_install".

error when you ran the installer?

Thanks

Daniel
12
Loading...