FlexUnit - FlexUnit4AirCIListener targets player 10.0.0

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

FlexUnit - FlexUnit4AirCIListener targets player 10.0.0

Cyrill Zadra
Hey Mike

FlexUnit4AirCIListener build.xml needs flashplayer version 10.0.0
(-target-player=10.0.0). Is there any specific reason that only this
projects targets this player or can it be removed?

Cyrill

Reply | Threaded
Open this post in threaded view
|

Re: FlexUnit - FlexUnit4AirCIListener targets player 10.0.0

doucettec
5 years later, I have the same problem.
I am trying to use AIR SDK 21 with Flash version 21.
We also try to run some Flex Unit tests.
Since this has a hard-coded reference to version 10.0.0, I either have to
find that version of playerglobal.swc and install it to my current FLEX SDK,
or I have to change the reference.
I am currently leaning towards forking the flexunit repository and changing
the reference.
Also - I am unable to find version 10.0 of playerglobal.swc, at least from
this website:
https://www.adobe.com/devnet/articles/flashplayer-air-feature-list.html




--
Sent from: http://apache-flex-development.2333347.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: FlexUnit - FlexUnit4AirCIListener targets player 10.0.0

piotrz
Hi Charles,

Can you make pull request on GitHub with all the changes in FlexUnit?

I can review it and maybe merge.

Thanks,
Piotr

On Tue, Apr 3, 2018, 01:33 doucettec <[hidden email]> wrote:

> 5 years later, I have the same problem.
> I am trying to use AIR SDK 21 with Flash version 21.
> We also try to run some Flex Unit tests.
> Since this has a hard-coded reference to version 10.0.0, I either have to
> find that version of playerglobal.swc and install it to my current FLEX
> SDK,
> or I have to change the reference.
> I am currently leaning towards forking the flexunit repository and changing
> the reference.
> Also - I am unable to find version 10.0 of playerglobal.swc, at least from
> this website:
> https://www.adobe.com/devnet/articles/flashplayer-air-feature-list.html
>
>
>
>
> --
> Sent from: http://apache-flex-development.2333347.n4.nabble.com/
>
Reply | Threaded
Open this post in threaded view
|

Re: FlexUnit - FlexUnit4AirCIListener targets player 10.0.0

Alex Harui-2
I'm pretty sure Apache Flex and Apache Royale (FlexJS) are using FlexUnit
without player 10.  You can take a look at how that is set up in the
flex-sdk and royale-asjs/flex-asjs repos.

HTH,
-Alex

On 4/2/18, 8:07 PM, "Piotr Zarzycki" <[hidden email]> wrote:

>Hi Charles,
>
>Can you make pull request on GitHub with all the changes in FlexUnit?
>
>I can review it and maybe merge.
>
>Thanks,
>Piotr
>
>On Tue, Apr 3, 2018, 01:33 doucettec <[hidden email]> wrote:
>
>> 5 years later, I have the same problem.
>> I am trying to use AIR SDK 21 with Flash version 21.
>> We also try to run some Flex Unit tests.
>> Since this has a hard-coded reference to version 10.0.0, I either have
>>to
>> find that version of playerglobal.swc and install it to my current FLEX
>> SDK,
>> or I have to change the reference.
>> I am currently leaning towards forking the flexunit repository and
>>changing
>> the reference.
>> Also - I am unable to find version 10.0 of playerglobal.swc, at least
>>from
>> this website:
>>
>>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.adob
>>e.com%2Fdevnet%2Farticles%2Fflashplayer-air-feature-list.html&data=02%7C0
>>1%7Caharui%40adobe.com%7Cc78fe8bd2b2a4dbf84c908d5991007dc%7Cfa7b1b5a7b344
>>38794aed2c178decee1%7C0%7C0%7C636583216484198532&sdata=RGjVOMKhDVc%2BY7jn
>>Hq6G12huxCqONqXNXgLCEzTpBYs%3D&reserved=0
>>
>>
>>
>>
>> --
>> Sent from:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-fl
>>ex-development.2333347.n4.nabble.com%2F&data=02%7C01%7Caharui%40adobe.com
>>%7Cc78fe8bd2b2a4dbf84c908d5991007dc%7Cfa7b1b5a7b34438794aed2c178decee1%7C
>>0%7C0%7C636583216484198532&sdata=ZJ7CBBf1FjI1NSZUfIgIGRnT2Y%2BNmI3OPdsKIl
>>%2FuCfU%3D&reserved=0
>>

Reply | Threaded
Open this post in threaded view
|

RE: FlexUnit - FlexUnit4AirCIListener targets player 10.0.0

Michael A. Labriola
Alex-

It's actually mainly just the compc target-player in the build.xml of the CI project. So the issue would only appear if trying to launch the a flash or air instance to run tests against.

Cyril actually asked me this question (as noted about 5 years ago) and I completely missed it until today.

The constant just needs to be moved to a property in the build.xml instead of coded inline. It was just an oversight that was never fixed. It's actually in 2 spots, the compile target and the report target. If I find time in the next week or so, I can try to get the PR in, else it really is just making a variable with a default and using it so that it can be passed in.

Mike

-----Original Message-----
From: Alex Harui <[hidden email]>
Sent: Tuesday, April 3, 2018 1:07 AM
To: [hidden email]
Subject: Re: FlexUnit - FlexUnit4AirCIListener targets player 10.0.0

I'm pretty sure Apache Flex and Apache Royale (FlexJS) are using FlexUnit without player 10.  You can take a look at how that is set up in the flex-sdk and royale-asjs/flex-asjs repos.

HTH,
-Alex

On 4/2/18, 8:07 PM, "Piotr Zarzycki" <[hidden email]> wrote:

>Hi Charles,
>
>Can you make pull request on GitHub with all the changes in FlexUnit?
>
>I can review it and maybe merge.
>
>Thanks,
>Piotr
>
>On Tue, Apr 3, 2018, 01:33 doucettec <[hidden email]> wrote:
>
>> 5 years later, I have the same problem.
>> I am trying to use AIR SDK 21 with Flash version 21.
>> We also try to run some Flex Unit tests.
>> Since this has a hard-coded reference to version 10.0.0, I either
>>have to  find that version of playerglobal.swc and install it to my
>>current FLEX  SDK,  or I have to change the reference.
>> I am currently leaning towards forking the flexunit repository and
>>changing  the reference.
>> Also - I am unable to find version 10.0 of playerglobal.swc, at least
>>from  this website:
>>
>>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.a
>>dob
>>e.com%2Fdevnet%2Farticles%2Fflashplayer-air-feature-list.html&data=02%
>>7C0
>>1%7Caharui%40adobe.com%7Cc78fe8bd2b2a4dbf84c908d5991007dc%7Cfa7b1b5a7b
>>344
>>38794aed2c178decee1%7C0%7C0%7C636583216484198532&sdata=RGjVOMKhDVc%2BY
>>7jn
>>Hq6G12huxCqONqXNXgLCEzTpBYs%3D&reserved=0
>>
>>
>>
>>
>> --
>> Sent from:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache
>>-fl
>>ex-development.2333347.n4.nabble.com%2F&data=02%7C01%7Caharui%40adobe.
>>com
>>%7Cc78fe8bd2b2a4dbf84c908d5991007dc%7Cfa7b1b5a7b34438794aed2c178decee1
>>%7C
>>0%7C0%7C636583216484198532&sdata=ZJ7CBBf1FjI1NSZUfIgIGRnT2Y%2BNmI3OPds
>>KIl
>>%2FuCfU%3D&reserved=0
>>

Reply | Threaded
Open this post in threaded view
|

Re: FlexUnit - FlexUnit4AirCIListener targets player 10.0.0

Alex Harui-2
Hi Mike,

Good to hear from you.  You might actually have commit privileges and can
skip the PR step.

FlexJS/Royale does launch FlashPlayer to test the SWF output and we aren't
noticing any issues.  But it could be that someone fixed this in our build
scripts.

Thanks,
-Alex

On 4/13/18, 12:51 PM, "Michael A. Labriola" <[hidden email]>
wrote:

>Alex-
>
>It's actually mainly just the compc target-player in the build.xml of the
>CI project. So the issue would only appear if trying to launch the a
>flash or air instance to run tests against.
>
>Cyril actually asked me this question (as noted about 5 years ago) and I
>completely missed it until today.
>
>The constant just needs to be moved to a property in the build.xml
>instead of coded inline. It was just an oversight that was never fixed.
>It's actually in 2 spots, the compile target and the report target. If I
>find time in the next week or so, I can try to get the PR in, else it
>really is just making a variable with a default and using it so that it
>can be passed in.
>
>Mike
>
>-----Original Message-----
>From: Alex Harui <[hidden email]>
>Sent: Tuesday, April 3, 2018 1:07 AM
>To: [hidden email]
>Subject: Re: FlexUnit - FlexUnit4AirCIListener targets player 10.0.0
>
>I'm pretty sure Apache Flex and Apache Royale (FlexJS) are using FlexUnit
>without player 10.  You can take a look at how that is set up in the
>flex-sdk and royale-asjs/flex-asjs repos.
>
>HTH,
>-Alex
>
>On 4/2/18, 8:07 PM, "Piotr Zarzycki" <[hidden email]> wrote:
>
>>Hi Charles,
>>
>>Can you make pull request on GitHub with all the changes in FlexUnit?
>>
>>I can review it and maybe merge.
>>
>>Thanks,
>>Piotr
>>
>>On Tue, Apr 3, 2018, 01:33 doucettec <[hidden email]> wrote:
>>
>>> 5 years later, I have the same problem.
>>> I am trying to use AIR SDK 21 with Flash version 21.
>>> We also try to run some Flex Unit tests.
>>> Since this has a hard-coded reference to version 10.0.0, I either
>>>have to  find that version of playerglobal.swc and install it to my
>>>current FLEX  SDK,  or I have to change the reference.
>>> I am currently leaning towards forking the flexunit repository and
>>>changing  the reference.
>>> Also - I am unable to find version 10.0 of playerglobal.swc, at least
>>>from  this website:
>>>
>>>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.a
>>>dob
>>>e.com%2Fdevnet%2Farticles%2Fflashplayer-air-feature-list.html&data=02%
>>>7C0
>>>1%7Caharui%40adobe.com%7Cc78fe8bd2b2a4dbf84c908d5991007dc%7Cfa7b1b5a7b
>>>344
>>>38794aed2c178decee1%7C0%7C0%7C636583216484198532&sdata=RGjVOMKhDVc%2BY
>>>7jn
>>>Hq6G12huxCqONqXNXgLCEzTpBYs%3D&reserved=0
>>>
>>>
>>>
>>>
>>> --
>>> Sent from:
>>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache
>>>-fl
>>>ex-development.2333347.n4.nabble.com%2F&data=02%7C01%7Caharui%40adobe.
>>>com
>>>%7Cc78fe8bd2b2a4dbf84c908d5991007dc%7Cfa7b1b5a7b34438794aed2c178decee1
>>>%7C
>>>0%7C0%7C636583216484198532&sdata=ZJ7CBBf1FjI1NSZUfIgIGRnT2Y%2BNmI3OPds
>>>KIl
>>>%2FuCfU%3D&reserved=0
>>>
>