Help with 0.8

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Help with 0.8

Jim Norris

Hi-

 

I had previously setup the Hello World sample using FlexJS 0.7.  I installed 0.8 and I am getting an internal build error that appears to be related to the Java SDK version.  The project runs find if I switch back to version 0.7.

 

I downloaded and ran the installer for Java SDK 1.8 but continued to get the same error.  I also set the environment variable for JAVA_HOME to the new Java SDK folder, restarted Flash Builder, but the trace is still indicating that it is using Java 1.6.

 

If anyone has any advice on how to correct this I would appreciate it.

 

Error log:

 

java.lang.UnsupportedClassVersionError: com/google/javascript/jscomp/ErrorManager : Unsupported major.minor version 51.0

 

 

Session data:

 

eclipse.buildId=M20110909-1335

java.version=1.6.0_31

java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US

Command-line arguments:  -os win32 -ws win32 -arch x86_64

 

 

 

Thanks,

 

Jim Norris

Office: 678-694-8809

Cell: 404-819-6823

[hidden email]

See me on LinkedIn

Click to view The new e-work.com video

 

The information transmitted in this electronic communication is intended only for the person(s) or entity to whom it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited.

 

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Help with 0.8

Harbs
I know Yishay changed the version of Java in his FB installation, but I don’t remember the details.

Is this helpful?
https://www.experts-exchange.com/questions/28699151/how-can-flash-builder-4-X-version-make-use-of-java-8.html <https://www.experts-exchange.com/questions/28699151/how-can-flash-builder-4-X-version-make-use-of-java-8.html>

> On Jul 26, 2017, at 7:24 PM, Jim Norris <[hidden email]> wrote:
>
> Hi-
>  
> I had previously setup the Hello World sample using FlexJS 0.7.  I installed 0.8 and I am getting an internal build error that appears to be related to the Java SDK version.  The project runs find if I switch back to version 0.7.
>  
> I downloaded and ran the installer for Java SDK 1.8 but continued to get the same error.  I also set the environment variable for JAVA_HOME to the new Java SDK folder, restarted Flash Builder, but the trace is still indicating that it is using Java 1.6.
>  
> If anyone has any advice on how to correct this I would appreciate it.
>  
> Error log:
>  
> java.lang.UnsupportedClassVersionError: com/google/javascript/jscomp/ErrorManager : Unsupported major.minor version 51.0
>  
>  
> Session data:
>  
> eclipse.buildId=M20110909-1335
> java.version=1.6.0_31
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
> Command-line arguments:  -os win32 -ws win32 -arch x86_64
>  
>  
>  
> Thanks,
>  
> Jim Norris
> Office: 678-694-8809
> Cell: 404-819-6823
> [hidden email] <mailto:[hidden email]>
> See me on LinkedIn <https://www.linkedin.com/in/jim-norris-376966108/>
>
> Click to view The new e-work.com <https://youtu.be/KLX4KZaewjQ> video
>  
> The information transmitted in this electronic communication is intended only for the person(s) or entity to whom it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Help with 0.8

yishayw
In reply to this post by Jim Norris
Can you describe what you’re doing? Running a build? If so, how? If you’re using external tool you might want to go to the Environment tab in the external configuration settings and set JAVA_HOME there.

From: Jim Norris<mailto:[hidden email]>
Sent: Wednesday, July 26, 2017 7:24 PM
To: [hidden email]<mailto:[hidden email]>
Subject: Help with 0.8

Hi-

I had previously setup the Hello World sample using FlexJS 0.7.  I installed 0.8 and I am getting an internal build error that appears to be related to the Java SDK version.  The project runs find if I switch back to version 0.7.

I downloaded and ran the installer for Java SDK 1.8 but continued to get the same error.  I also set the environment variable for JAVA_HOME to the new Java SDK folder, restarted Flash Builder, but the trace is still indicating that it is using Java 1.6.

If anyone has any advice on how to correct this I would appreciate it.

Error log:

java.lang.UnsupportedClassVersionError: com/google/javascript/jscomp/ErrorManager : Unsupported major.minor version 51.0


Session data:

eclipse.buildId=M20110909-1335
java.version=1.6.0_31
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86_64



Thanks,

Jim Norris
Office: 678-694-8809
Cell: 404-819-6823
[hidden email]<mailto:[hidden email]>
See me on LinkedIn<https://www.linkedin.com/in/jim-norris-376966108/>
[cid:image001.png@01D2FBB5.88881E00]
Click to view The new e-work.com<https://youtu.be/KLX4KZaewjQ> video

The information transmitted in this electronic communication is intended only for the person(s) or entity to whom it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Help with 0.8

Jim Norris
In reply to this post by Harbs
It did help.  I had to copy the jre folder from the 1.8 JDK install to the Flash Builder application directory (replacing the old jre folder), and that fixed it.



Thanks very much for the help.

Jim

-----Original Message-----
From: Harbs [mailto:[hidden email]]
Sent: Wednesday, July 26, 2017 12:33 PM
To: [hidden email]
Subject: Re: Help with 0.8

I know Yishay changed the version of Java in his FB installation, but I don’t remember the details.

Is this helpful?
https://www.experts-exchange.com/questions/28699151/how-can-flash-builder-4-X-version-make-use-of-java-8.html <https://www.experts-exchange.com/questions/28699151/how-can-flash-builder-4-X-version-make-use-of-java-8.html>

> On Jul 26, 2017, at 7:24 PM, Jim Norris <[hidden email]> wrote:
>
> Hi-
>  
> I had previously setup the Hello World sample using FlexJS 0.7.  I installed 0.8 and I am getting an internal build error that appears to be related to the Java SDK version.  The project runs find if I switch back to version 0.7.
>  
> I downloaded and ran the installer for Java SDK 1.8 but continued to get the same error.  I also set the environment variable for JAVA_HOME to the new Java SDK folder, restarted Flash Builder, but the trace is still indicating that it is using Java 1.6.
>  
> If anyone has any advice on how to correct this I would appreciate it.
>  
> Error log:
>  
> java.lang.UnsupportedClassVersionError:
> com/google/javascript/jscomp/ErrorManager : Unsupported major.minor
> version 51.0
>  
>  
> Session data:
>  
> eclipse.buildId=M20110909-1335
> java.version=1.6.0_31
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
> Command-line arguments:  -os win32 -ws win32 -arch x86_64
>  
>  
>  
> Thanks,
>  
> Jim Norris
> Office: 678-694-8809
> Cell: 404-819-6823
> [hidden email] <mailto:[hidden email]> See me on
> LinkedIn <https://www.linkedin.com/in/jim-norris-376966108/>
>
> Click to view The new e-work.com <https://youtu.be/KLX4KZaewjQ> video
>  
> The information transmitted in this electronic communication is intended only for the person(s) or entity to whom it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Help with 0.8

Jim Norris
In reply to this post by Harbs
Do you have an example project you would suggest as a good starting point for learning FlexJS?  I tried the FlexJSStore and it seems like it has some issues.

I am trying to setup some (of my own) simple pages and running into anomalies in behavior between the swf output and the js-release and I would like to look at something that is setup properly to make sure I understand how I should be doing things.

Again, appreciate your feedback.





Thanks,

Jim

-----Original Message-----
From: Jim Norris [mailto:[hidden email]]
Sent: Wednesday, July 26, 2017 1:42 PM
To: '[hidden email]' <[hidden email]>
Subject: RE: Help with 0.8

It did help.  I had to copy the jre folder from the 1.8 JDK install to the Flash Builder application directory (replacing the old jre folder), and that fixed it.



Thanks very much for the help.

Jim

-----Original Message-----
From: Harbs [mailto:[hidden email]]
Sent: Wednesday, July 26, 2017 12:33 PM
To: [hidden email]
Subject: Re: Help with 0.8

I know Yishay changed the version of Java in his FB installation, but I don’t remember the details.

Is this helpful?
https://www.experts-exchange.com/questions/28699151/how-can-flash-builder-4-X-version-make-use-of-java-8.html <https://www.experts-exchange.com/questions/28699151/how-can-flash-builder-4-X-version-make-use-of-java-8.html>

> On Jul 26, 2017, at 7:24 PM, Jim Norris <[hidden email]> wrote:
>
> Hi-
>  
> I had previously setup the Hello World sample using FlexJS 0.7.  I installed 0.8 and I am getting an internal build error that appears to be related to the Java SDK version.  The project runs find if I switch back to version 0.7.
>  
> I downloaded and ran the installer for Java SDK 1.8 but continued to get the same error.  I also set the environment variable for JAVA_HOME to the new Java SDK folder, restarted Flash Builder, but the trace is still indicating that it is using Java 1.6.
>  
> If anyone has any advice on how to correct this I would appreciate it.
>  
> Error log:
>  
> java.lang.UnsupportedClassVersionError:
> com/google/javascript/jscomp/ErrorManager : Unsupported major.minor
> version 51.0
>  
>  
> Session data:
>  
> eclipse.buildId=M20110909-1335
> java.version=1.6.0_31
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
> Command-line arguments:  -os win32 -ws win32 -arch x86_64
>  
>  
>  
> Thanks,
>  
> Jim Norris
> Office: 678-694-8809
> Cell: 404-819-6823
> [hidden email] <mailto:[hidden email]> See me on
> LinkedIn <https://www.linkedin.com/in/jim-norris-376966108/>
>
> Click to view The new e-work.com <https://youtu.be/KLX4KZaewjQ> video
>  
> The information transmitted in this electronic communication is intended only for the person(s) or entity to whom it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Help with 0.8

piotrz
Jim,

DataBindingExample look the simplest. [1]
MDLExample - contains representation of all components in our MDL port. [2]

[1] https://goo.gl/JSgWzN
[2] https://goo.gl/hgoaXz

Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

MDL and Material Components Web (was Re: Help with 0.8)

Harbs
FYI, Material Components Web is the replacement for MDL.

It has the advantage of being simpler and ultimately more capable.

I’ve been keeping half an eye on it, and it’s getting pretty far along. The roadmap looks very good too.[2]

At some point, some ambitious souls might want to make a component set for those as well… ;-)

> On Jul 27, 2017, at 12:27 AM, piotrz <[hidden email]> wrote:
>
> MDLExample - contains representation of all components in our MDL port. [2]

[1]https://material.io/components/web/ <https://material.io/components/web/>
[2]https://www.pivotaltracker.com/n/projects/1664011 <https://www.pivotaltracker.com/n/projects/1664011>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MDL and Material Components Web (was Re: Help with 0.8)

piotrz
Hah Harbs! That ambitious soul thinking about it every day :)
Wish someone could give me time for this one <3 :)

Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: MDL and Material Components Web (was Re: Help with 0.8)

yishayw
Maybe slightly off topic but I would love for an ambitious soul to skin a nice default FlexJS look and feel. I would be glad to help with that, but we need someone (else) to come up with a good graphic design.

From: piotrz<mailto:[hidden email]>
Sent: Thursday, July 27, 2017 9:12 AM
To: [hidden email]<mailto:[hidden email]>
Subject: Re: MDL and Material Components Web (was Re: Help with 0.8)

Hah Harbs! That ambitious soul thinking about it every day :)
Wish someone could give me time for this one <3 :)

Piotr



-----
Apache Flex PMC
[hidden email]
--
View this message in context: http://apache-flex-development.2333347.n4.nabble.com/Help-with-0-8-tp63568p63583.html
Sent from the Apache Flex Development mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: MDL and Material Components Web (was Re: Help with 0.8)

piotrz
Yep! In that case I just get back to live our old topic [1] :)

[1] http://apache-flex-users.2333346.n4.nabble.com/Re-FlexJS-Wanted-UX-UI-Design-Proposals-td14439.html

Thanks,
Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: MDL and Material Components Web (was Re: Help with 0.8)

Carlos Rovira
Hi!,

right, as we discussed, when material components born and MDL was
deprecated we were at 70% of MDL FlexJS component set.
We decided to let MC to evolve since it was at a early stage.
I think most of the work done on MDL could be a good base for an MC
component set

In the other hand, I always want to promote our own sets since it could
allow as to create themes around.
The main problem with importing another tech or frameworks like MDL,
CreateJS is that you end with their own implementation each one separated
from the other.
Since each one has its own controls and rules.

So If you ask me what would be better, I would prefer to implement themes
in our own component set (Express) than create another MC set
MDL was done as well with the intention to have some functional components
with a great look since all examples of FlexJS was operative, but the look
and feel was very poor and that's a problem from a marketing point of view
for FlexJS and to increase FlexJS adoption



2017-07-27 10:26 GMT+02:00 piotrz <[hidden email]>:

> Yep! In that case I just get back to live our old topic [1] :)
>
> [1]
> http://apache-flex-users.2333346.n4.nabble.com/Re-
> FlexJS-Wanted-UX-UI-Design-Proposals-td14439.html
>
> Thanks,
> Piotr
>
>
>
> -----
> Apache Flex PMC
> [hidden email]
> --
> View this message in context: http://apache-flex-
> development.2333347.n4.nabble.com/Help-with-0-8-tp63568p63587.html
> Sent from the Apache Flex Development mailing list archive at Nabble.com.
>



--

<http://www.codeoscopic.com>

Carlos Rovira

Director General

M: +34 607 22 60 05

http://www.codeoscopic.com

http://www.avant2.es


Conocenos en 1 minuto! <https://youtu.be/P2IEAYDG5HU>


Este mensaje se dirige exclusivamente a su destinatario y puede contener
información privilegiada o confidencial. Si ha recibido este mensaje por
error, le rogamos que nos lo comunique inmediatamente por esta misma vía y
proceda a su destrucción.

De la vigente Ley Orgánica de Protección de Datos (15/1999), le comunicamos
que sus datos forman parte de un fichero cuyo responsable es CODEOSCOPIC
S.A. La finalidad de dicho tratamiento es facilitar la prestación del
servicio o información solicitados, teniendo usted derecho de acceso,
rectificación, cancelación y oposición de sus datos dirigiéndose a nuestras
oficinas c/ Paseo de la Habana 9-11, 28036, Madrid con la documentación
necesaria.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Help with 0.8

Jim Norris
In reply to this post by Harbs
Hello-

I am trying to use some components and having some trouble (both running a swf and sometimes different issues when exporting JS).  For basics, I want to setup some HTML text, but I get an exception when using the HTMLText component.  See trace below.  Let me know if there may be additional setup steps for FlashBuilder I am unaware of.  I also tried TextArea which displayed in swf (with a lot of Mouse event errors) but not when I exported to JS.
 

TypeError: Error #1007: Instantiation attempted on a non-constructor.
        at org.apache.flex.core::UIBase/get model()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/Basic/src/main/flex/org/apache/flex/core/UIBase.as:842]
        at org.apache.flex.html::HTMLText/addedToParent()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/HTML/src/main/flex/org/apache/flex/html/HTMLText.as:99]
        at org.apache.flex.core::UIBase/addElement()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/Basic/src/main/flex/org/apache/flex/core/UIBase.as:1139]
        at org.apache.flex.core::GroupBase/addElement()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/Basic/src/main/flex/org/apache/flex/core/GroupBase.as:301]
        at org.apache.flex.utils::MXMLDataInterpreter$/initializeStrandBasedObject()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/Core/src/main/flex/org/apache/flex/utils/MXMLDataInterpreter.as:300]
        at org.apache.flex.utils::MXMLDataInterpreter$/generateMXMLArray()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/Core/src/main/flex/org/apache/flex/utils/MXMLDataInterpreter.as:162]
        at org.apache.flex.utils::MXMLDataInterpreter$/generateMXMLInstances()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/Core/src/main/flex/org/apache/flex/utils/MXMLDataInterpreter.as:341]
        at org.apache.flex.core::View/addedToParent()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/Basic/src/main/flex/org/apache/flex/core/View.as:68]
        at org.apache.flex.core::Application/addElement()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/Basic/src/main/flex/org/apache/flex/core/Application.as:442]
        at org.apache.flex.core::Application/initialize()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/Basic/src/main/flex/org/apache/flex/core/Application.as:189]
        at org.apache.flex.core::Application/initHandler()[/Users/aharui/git/flex/release/flex-asjs/frameworks/projects/Basic/src/main/flex/org/apache/flex/core/Application.as:153]



Thanks for any help.

Jim

-----Original Message-----
From: Jim Norris [mailto:[hidden email]]
Sent: Wednesday, July 26, 2017 4:37 PM
To: '[hidden email]' <[hidden email]>
Subject: RE: Help with 0.8

Do you have an example project you would suggest as a good starting point for learning FlexJS?  I tried the FlexJSStore and it seems like it has some issues.

I am trying to setup some (of my own) simple pages and running into anomalies in behavior between the swf output and the js-release and I would like to look at something that is setup properly to make sure I understand how I should be doing things.

Again, appreciate your feedback.





Thanks,

Jim

-----Original Message-----
From: Jim Norris [mailto:[hidden email]]
Sent: Wednesday, July 26, 2017 1:42 PM
To: '[hidden email]' <[hidden email]>
Subject: RE: Help with 0.8

It did help.  I had to copy the jre folder from the 1.8 JDK install to the Flash Builder application directory (replacing the old jre folder), and that fixed it.



Thanks very much for the help.

Jim

-----Original Message-----
From: Harbs [mailto:[hidden email]]
Sent: Wednesday, July 26, 2017 12:33 PM
To: [hidden email]
Subject: Re: Help with 0.8

I know Yishay changed the version of Java in his FB installation, but I don’t remember the details.

Is this helpful?
https://www.experts-exchange.com/questions/28699151/how-can-flash-builder-4-X-version-make-use-of-java-8.html <https://www.experts-exchange.com/questions/28699151/how-can-flash-builder-4-X-version-make-use-of-java-8.html>

> On Jul 26, 2017, at 7:24 PM, Jim Norris <[hidden email]> wrote:
>
> Hi-
>  
> I had previously setup the Hello World sample using FlexJS 0.7.  I installed 0.8 and I am getting an internal build error that appears to be related to the Java SDK version.  The project runs find if I switch back to version 0.7.
>  
> I downloaded and ran the installer for Java SDK 1.8 but continued to get the same error.  I also set the environment variable for JAVA_HOME to the new Java SDK folder, restarted Flash Builder, but the trace is still indicating that it is using Java 1.6.
>  
> If anyone has any advice on how to correct this I would appreciate it.
>  
> Error log:
>  
> java.lang.UnsupportedClassVersionError:
> com/google/javascript/jscomp/ErrorManager : Unsupported major.minor
> version 51.0
>  
>  
> Session data:
>  
> eclipse.buildId=M20110909-1335
> java.version=1.6.0_31
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
> Command-line arguments:  -os win32 -ws win32 -arch x86_64
>  
>  
>  
> Thanks,
>  
> Jim Norris
> Office: 678-694-8809
> Cell: 404-819-6823
> [hidden email] <mailto:[hidden email]> See me on
> LinkedIn <https://www.linkedin.com/in/jim-norris-376966108/>
>
> Click to view The new e-work.com <https://youtu.be/KLX4KZaewjQ> video
>  
> The information transmitted in this electronic communication is intended only for the person(s) or entity to whom it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Help with 0.8

piotrz
Hi Jim,

Could you show your code. It would be easier to see where the problem could be.

Thanks,
Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Help with 0.8

Jim Norris
I made it as simple as I could:


<?xml version="1.0" encoding="utf-8"?>
<js:Application xmlns:fx="http://ns.adobe.com/mxml/2009"
       
xmlns:js="library://ns.apache.org/flexjs/express"
xmlns:basic="library://ns.apache.org/flexjs/basic"
                                >
       
        <fx:Style>
                @namespace js "library://ns.apache.org/flexjs/express";
                .bigText{
                        color:#005192;
                        font-size:32px;
                }
               
                .htmlStuff{
                        color:#ffff00;
                }
               
        </fx:Style>
       
        <js:initialView>
                <js:View>
                        <js:Label y="30" x="20" id="titleText"
className="bigText" text="Flex JS"/>
                        <basic:HTMLText y="100" x="20" id="htmlText"
className="htmlStuff" html="Html text goes here!"  />
                </js:View>
        </js:initialView>
       
</js:Application>




Thanks,

Jim

-----Original Message-----
From: piotrz [mailto:[hidden email]]
Sent: Friday, July 28, 2017 10:42 AM
To: [hidden email]
Subject: RE: Help with 0.8

Hi Jim,

Could you show your code. It would be easier to see where the problem could
be.

Thanks,
Piotr



-----
Apache Flex PMC
[hidden email]
--
View this message in context:
http://apache-flex-development.2333347.n4.nabble.com/Help-with-0-8-tp63568p6
3593.html
Sent from the Apache Flex Development mailing list archive at Nabble.com.

Loading...