Installer Issue: Host binaries elsewhere?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Installer Issue: Host binaries elsewhere?

Alex Harui-2
Hi Flex PMC.

As you hopefully know, lots of people are having trouble with the installer.  Can someone look to see if we've had any successful 4.16.1 installs in the past week or two?

The issue seems to be about fetching the mirror data over HTTPS.  Not sure why it doesn't work.  But one workaround might be to find a volunteer to host the binaries elsewhere without a mirror system that we can access over HTTP (I don't think HTTPS will work there either).  We might be able to add some thanks to the host in the installer.log.

Thoughts?
-Alex

Reply | Threaded
Open this post in threaded view
|

Re: Installer Issue: Host binaries elsewhere?

Harbs
What kind of data usage are we talking about?

What about open source CDN options?
https://www.maxcdn.com/open-source/ <https://www.maxcdn.com/open-source/>
https://www.keycdn.com/open-source-cdn

Harbs

> On May 31, 2018, at 11:51 AM, Alex Harui <[hidden email]> wrote:
>
> Hi Flex PMC.
>
> As you hopefully know, lots of people are having trouble with the installer.  Can someone look to see if we've had any successful 4.16.1 installs in the past week or two?
>
> The issue seems to be about fetching the mirror data over HTTPS.  Not sure why it doesn't work.  But one workaround might be to find a volunteer to host the binaries elsewhere without a mirror system that we can access over HTTP (I don't think HTTPS will work there either).  We might be able to add some thanks to the host in the installer.log.
>
> Thoughts?
> -Alex
>

Reply | Threaded
Open this post in threaded view
|

Re: Installer Issue: Host binaries elsewhere?

Alex Harui-2
Free CDN is also a solution.  I could go look at our analytics, but I'm hoping some other member of our community will step up and save me the time.  Old Flex Board Reports used to tell us about installer downloads.

-Alex

On 5/31/18, 2:03 AM, "Harbs" <[hidden email]> wrote:

    What kind of data usage are we talking about?
   
    What about open source CDN options?
    https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.maxcdn.com%2Fopen-source%2F&data=02%7C01%7Caharui%40adobe.com%7C5008893e818c44996ed508d5c6d54fab%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633541825301608&sdata=GQM14EfzDEzwjdja34IBi6cN20sZFMnNCa4K5AlylQ4%3D&reserved=0 <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.maxcdn.com%2Fopen-source%2F&data=02%7C01%7Caharui%40adobe.com%7C5008893e818c44996ed508d5c6d54fab%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633541825301608&sdata=GQM14EfzDEzwjdja34IBi6cN20sZFMnNCa4K5AlylQ4%3D&reserved=0>
    https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.keycdn.com%2Fopen-source-cdn&data=02%7C01%7Caharui%40adobe.com%7C5008893e818c44996ed508d5c6d54fab%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633541825301608&sdata=70NWXCLbf57Ca4cNQBSldTF4EzbU4iqTyflLkH8VFcs%3D&reserved=0
   
    Harbs
   
    > On May 31, 2018, at 11:51 AM, Alex Harui <[hidden email]> wrote:
    >
    > Hi Flex PMC.
    >
    > As you hopefully know, lots of people are having trouble with the installer.  Can someone look to see if we've had any successful 4.16.1 installs in the past week or two?
    >
    > The issue seems to be about fetching the mirror data over HTTPS.  Not sure why it doesn't work.  But one workaround might be to find a volunteer to host the binaries elsewhere without a mirror system that we can access over HTTP (I don't think HTTPS will work there either).  We might be able to add some thanks to the host in the installer.log.
    >
    > Thoughts?
    > -Alex
    >
   
   

Reply | Threaded
Open this post in threaded view
|

Re: Installer Issue: Host binaries elsewhere?

Justin Mclean-5
In reply to this post by Alex Harui-2
Hi,

> As you hopefully know, lots of people are having trouble with the installer.  Can someone look to see if we've had any successful 4.16.1 installs in the past week or two?

Looks like all download are failing either with a timeout or other error. It doesn’t seem to be OS specific but it’s looks to be SDK version specific.

From 14th May(and possibly earlier)  onwards it looks like all 4.16.1 and 4.1`6.0 are failing.

/track-installer.html?failure=true&label=Apache Flex SDK 4.16.1&version=4.16.1&os=windows&installerversion=3.3.1&info=Timeout
846 failures

/track-installer.html?failure=true&label=Apache Flex SDK 4.16.1&version=4.16.1&os=mac&installerversion=3.3.1&info=Timeout
377 failures

/track-installer.html?failure=true&label=Apache Flex SDK 4.16.0&version=4.16.0&os=windows&installerversion=3.3.1&info=Timeout
64 failures

There was a small number of successful 4.15.0 downloads and I can see success for 4.13.0 and 4.14.1 as well.

/track-installer.html?label=Apache Flex SDK 4.15.0&version=4.15.0&os=windows&installerVersion=3.3.1

/track-installer.html?label=Apache Flex SDK 4.15.0&version=4.15.0&os=mac&installerVersion=3.3.1

Thanks,
Justin


Reply | Threaded
Open this post in threaded view
|

Re: Installer Issue: Host binaries elsewhere?

Justin Mclean-5
Hi,

> Looks like all download are failing either with a timeout or other error. It doesn’t seem to be OS specific but it’s looks to be SDK version specific.

I just tried it and I’m also getting a timeout. Given non 4.16 versions can be downloaded it looks to me tp be an issue with the configuration file or parking the mirror URL. I’ve run it though a proxy to see what call is failing but it doesn’t seem to show.

Calls to:
http://flex.apache.org/installer/sdk-installer-config-4.0.xml
http://flex.apache.org/installer/properties/en_AU.properties
http://flex.apache.org/single-mirror-url--xml.cgi

Are all successful but it not making a call to the mirror contained within the page returned by the cgi script. I would guess it failing to parse that information from the cgi page. However it looks like the cause of that issue is that it not passing the file to download to the cgi scrip.

Thanks,
Justin

Reply | Threaded
Open this post in threaded view
|

Re: Installer Issue: Host binaries elsewhere?

Justin Mclean
Administrator
Hi,

As mentioned in the other thread is issue is not SSL released but is released to our mirror CGI script. http://flex.apache.org/single-mirror-url--xml.cgi <http://flex.apache.org/single-mirror-url--xml.cgi> looks to be returning too much information and the installer’s code (in MirrorURLUtil) isn’t correctly parsing the mirror’s URL out of the info returned. It ends up with an invalid URL which times out when the installer tries to call it.

Thanks,
Justin