Installer is Timing Out.

classic Classic list List threaded Threaded
82 messages Options
12345
Reply | Threaded
Open this post in threaded view
|

Installer is Timing Out.

oharkins
Entire log is:

Installer version 3.3.1 (mac)
Using Locale: en_US
Fetched the SDK download mirror URL from the CGI.
Timeout
Installation aborted:
http://flex.apache.org/track-installer.html?failure=true&label=Apache Flex
SDK 4.16.1&version=4.16.1&os=mac&installerversion=3.3.1&info=Timeout


I cant get past the first screen, Flex Version 4.16.1
Air 29
Player 29.0



--
Sent from: http://apache-flex-development.2333347.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Joel Tan-3
Hi,

I am facing the same issue here after upgrading to version 3.3.1 (Mac).

Joel

On Thu, May 31, 2018 at 7:17 AM, oharkins <[hidden email]>
wrote:

> Entire log is:
>
> Installer version 3.3.1 (mac)
> Using Locale: en_US
> Fetched the SDK download mirror URL from the CGI.
> Timeout
> Installation aborted:
> http://flex.apache.org/track-installer.html?failure=true&label=Apache Flex
> SDK 4.16.1&version=4.16.1&os=mac&installerversion=3.3.1&info=Timeout
>
>
> I cant get past the first screen, Flex Version 4.16.1
> Air 29
> Player 29.0
>
>
>
> --
> Sent from: http://apache-flex-development.2333347.n4.nabble.com/
>
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Alex Harui-2
Hmm, that's interesting.  Does someone have time to try an older version of the installer?  I have crappy internet at the moment.

3.2 is available here: http://archive.apache.org/dist/flex/installer/3.2/binaries/
3.3 is available here: http://archive.apache.org/dist/flex/installer/3.3/binaries/

You will probably have to uninstall the 3.3.1 version before installing the older version.  Some has gone wonky with the HTTPS code.  Not sure what it is yet.  Folks can use the binary packages and Apache Ant as an alternative.  

Get the binary package from http://flex.apache.org/download-binaries.html
Unpack it.
Run "ant -f installer.xml"

HTH,
-Alex

On 5/30/18, 6:43 PM, "Joel Tan" <[hidden email]> wrote:

    Hi,
   
    I am facing the same issue here after upgrading to version 3.3.1 (Mac).
   
    Joel
   
    On Thu, May 31, 2018 at 7:17 AM, oharkins <[hidden email]>
    wrote:
   
    > Entire log is:
    >
    > Installer version 3.3.1 (mac)
    > Using Locale: en_US
    > Fetched the SDK download mirror URL from the CGI.
    > Timeout
    > Installation aborted:
    > https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apache.org%2Ftrack-installer.html%3Ffailure%3Dtrue%26label%3DApache&data=02%7C01%7Caharui%40adobe.com%7C77f8dfd71ea64e8ff6e808d5c697eaa3%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633278145970805&sdata=%2Bh4IvrRp38F4HURH65JJ7RRj8WQQZFDOKqb%2BH3Q4TYs%3D&reserved=0 Flex
    > SDK 4.16.1&version=4.16.1&os=mac&installerversion=3.3.1&info=Timeout
    >
    >
    > I cant get past the first screen, Flex Version 4.16.1
    > Air 29
    > Player 29.0
    >
    >
    >
    > --
    > Sent from: https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-flex-development.2333347.n4.nabble.com%2F&data=02%7C01%7Caharui%40adobe.com%7C77f8dfd71ea64e8ff6e808d5c697eaa3%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633278145970805&sdata=9ZKYzlh0m5xGXnWDyBOc3aWPCvhN2shl2ACyH9hFS6Y%3D&reserved=0
    >
   

Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Joel Tan-3
Hi,

Previously I was prompted to upgrade to new version (3.3.1), I click the
upgrade button to upgrade from the existing installer, it doesn't work
after I upgrade to the new version, it has timeout issue once I click the
Next button. I also try to uninstall the installer and reinstall again by
downloading the installer from the web, it still having the same issue
regardless of which version of SDK I choose.

Thanks.

Joel

On Thu, May 31, 2018 at 3:44 PM, Alex Harui <[hidden email]>
wrote:

> Hmm, that's interesting.  Does someone have time to try an older version
> of the installer?  I have crappy internet at the moment.
>
> 3.2 is available here: http://archive.apache.org/dist/flex/installer/3.2/
> binaries/
> 3.3 is available here: http://archive.apache.org/dist/flex/installer/3.3/
> binaries/
>
> You will probably have to uninstall the 3.3.1 version before installing
> the older version.  Some has gone wonky with the HTTPS code.  Not sure what
> it is yet.  Folks can use the binary packages and Apache Ant as an
> alternative.
>
> Get the binary package from http://flex.apache.org/download-binaries.html
> Unpack it.
> Run "ant -f installer.xml"
>
> HTH,
> -Alex
>
> On 5/30/18, 6:43 PM, "Joel Tan" <[hidden email]> wrote:
>
>     Hi,
>
>     I am facing the same issue here after upgrading to version 3.3.1 (Mac).
>
>     Joel
>
>     On Thu, May 31, 2018 at 7:17 AM, oharkins <[hidden email]>
>     wrote:
>
>     > Entire log is:
>     >
>     > Installer version 3.3.1 (mac)
>     > Using Locale: en_US
>     > Fetched the SDK download mirror URL from the CGI.
>     > Timeout
>     > Installation aborted:
>     > https://na01.safelinks.protection.outlook.com/?url=
> http%3A%2F%2Fflex.apache.org%2Ftrack-installer.html%
> 3Ffailure%3Dtrue%26label%3DApache&data=02%7C01%7Caharui%40adobe.com%
> 7C77f8dfd71ea64e8ff6e808d5c697eaa3%7Cfa7b1b5a7b34438794aed2c178de
> cee1%7C0%7C0%7C636633278145970805&sdata=%2Bh4IvrRp38F4HURH65JJ7RRj8WQQZ
> FDOKqb%2BH3Q4TYs%3D&reserved=0 Flex
>     > SDK 4.16.1&version=4.16.1&os=mac&installerversion=3.3.1&info=Timeout
>     >
>     >
>     > I cant get past the first screen, Flex Version 4.16.1
>     > Air 29
>     > Player 29.0
>     >
>     >
>     >
>     > --
>     > Sent from: https://na01.safelinks.protection.outlook.com/?url=
> http%3A%2F%2Fapache-flex-development.2333347.n4.nabble.
> com%2F&data=02%7C01%7Caharui%40adobe.com%7C77f8dfd71ea64e8ff6e808d5c697
> eaa3%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%
> 7C636633278145970805&sdata=9ZKYzlh0m5xGXnWDyBOc3aWPCvhN2s
> hl2ACyH9hFS6Y%3D&reserved=0
>     >
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Alex Harui-2
Hi Joel,

I thought there was a way to run the old version even though you were prompted to upgrade.

4.16.0 was also using the mirrors.  I just fixed that but if it still doesn't work for you the config file might be cached.  4.15.0 installed for me.

HTH,
-Alex

On 5/31/18, 2:16 AM, "Joel Tan" <[hidden email]> wrote:

    Hi,
   
    Previously I was prompted to upgrade to new version (3.3.1), I click the
    upgrade button to upgrade from the existing installer, it doesn't work
    after I upgrade to the new version, it has timeout issue once I click the
    Next button. I also try to uninstall the installer and reinstall again by
    downloading the installer from the web, it still having the same issue
    regardless of which version of SDK I choose.
   
    Thanks.
   
    Joel
   
    On Thu, May 31, 2018 at 3:44 PM, Alex Harui <[hidden email]>
    wrote:
   
    > Hmm, that's interesting.  Does someone have time to try an older version
    > of the installer?  I have crappy internet at the moment.
    >
    > 3.2 is available here: https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Farchive.apache.org%2Fdist%2Fflex%2Finstaller%2F3.2%2F&data=02%7C01%7Caharui%40adobe.com%7C4c104c945c0e4d1bc4cc08d5c6d735ea%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633549982502782&sdata=S6tdqmORPzdrX9Wojokey7qnUu%2BHLHWVbtMR6rhdv%2FY%3D&reserved=0
    > binaries/
    > 3.3 is available here: https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Farchive.apache.org%2Fdist%2Fflex%2Finstaller%2F3.3%2F&data=02%7C01%7Caharui%40adobe.com%7C4c104c945c0e4d1bc4cc08d5c6d735ea%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633549982502782&sdata=kTapzVwAvUW%2FdVoiCapQLoj2MA33oRQSa%2Fcj30cFOQs%3D&reserved=0
    > binaries/
    >
    > You will probably have to uninstall the 3.3.1 version before installing
    > the older version.  Some has gone wonky with the HTTPS code.  Not sure what
    > it is yet.  Folks can use the binary packages and Apache Ant as an
    > alternative.
    >
    > Get the binary package from https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apache.org%2Fdownload-binaries.html&data=02%7C01%7Caharui%40adobe.com%7C4c104c945c0e4d1bc4cc08d5c6d735ea%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633549982502782&sdata=snB5lZfTlFrVsmAx5JUw5VugC%2BbwtC2S67O6uB%2BAFZU%3D&reserved=0
    > Unpack it.
    > Run "ant -f installer.xml"
    >
    > HTH,
    > -Alex
    >
    > On 5/30/18, 6:43 PM, "Joel Tan" <[hidden email]> wrote:
    >
    >     Hi,
    >
    >     I am facing the same issue here after upgrading to version 3.3.1 (Mac).
    >
    >     Joel
    >
    >     On Thu, May 31, 2018 at 7:17 AM, oharkins <[hidden email]>
    >     wrote:
    >
    >     > Entire log is:
    >     >
    >     > Installer version 3.3.1 (mac)
    >     > Using Locale: en_US
    >     > Fetched the SDK download mirror URL from the CGI.
    >     > Timeout
    >     > Installation aborted:
    >     > https://na01.safelinks.protection.outlook.com/?url=
    > http%3A%2F%2Fflex.apache.org%2Ftrack-installer.html%
    > 3Ffailure%3Dtrue%26label%3DApache&data=02%7C01%7Caharui%40adobe.com%
    > 7C77f8dfd71ea64e8ff6e808d5c697eaa3%7Cfa7b1b5a7b34438794aed2c178de
    > cee1%7C0%7C0%7C636633278145970805&sdata=%2Bh4IvrRp38F4HURH65JJ7RRj8WQQZ
    > FDOKqb%2BH3Q4TYs%3D&reserved=0 Flex
    >     > SDK 4.16.1&version=4.16.1&os=mac&installerversion=3.3.1&info=Timeout
    >     >
    >     >
    >     > I cant get past the first screen, Flex Version 4.16.1
    >     > Air 29
    >     > Player 29.0
    >     >
    >     >
    >     >
    >     > --
    >     > Sent from: https://na01.safelinks.protection.outlook.com/?url=
    > http%3A%2F%2Fapache-flex-development.2333347.n4.nabble.
    > com%2F&data=02%7C01%7Caharui%40adobe.com%7C77f8dfd71ea64e8ff6e808d5c697
    > eaa3%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%
    > 7C636633278145970805&sdata=9ZKYzlh0m5xGXnWDyBOc3aWPCvhN2s
    > hl2ACyH9hFS6Y%3D&reserved=0
    >     >
    >
    >
    >
   

Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

oharkins
In reply to this post by Alex Harui-2
I tried the older version 3.3 and it das the same issue times out. I can't
see what it is trying to access.


Alex Harui-2 wrote

> Hmm, that's interesting.  Does someone have time to try an older version
> of the installer?  I have crappy internet at the moment.
>
> 3.2 is available here:
> http://archive.apache.org/dist/flex/installer/3.2/binaries/
> 3.3 is available here:
> http://archive.apache.org/dist/flex/installer/3.3/binaries/
>
> You will probably have to uninstall the 3.3.1 version before installing
> the older version.  Some has gone wonky with the HTTPS code.  Not sure
> what it is yet.  Folks can use the binary packages and Apache Ant as an
> alternative.  
>
> Get the binary package from http://flex.apache.org/download-binaries.html
> Unpack it.
> Run "ant -f installer.xml"
>
> HTH,
> -Alex
>
> On 5/30/18, 6:43 PM, "Joel Tan" &lt;

> organet.my@

> &gt; wrote:
>
>     Hi,
>    
>     I am facing the same issue here after upgrading to version 3.3.1
> (Mac).
>    
>     Joel
>    
>     On Thu, May 31, 2018 at 7:17 AM, oharkins &lt;

> odisjamesharkins@

> &gt;
>     wrote:
>    
>     > Entire log is:
>     >
>     > Installer version 3.3.1 (mac)
>     > Using Locale: en_US
>     > Fetched the SDK download mirror URL from the CGI.
>     > Timeout
>     > Installation aborted:
>     >
> https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apache.org%2Ftrack-installer.html%3Ffailure%3Dtrue%26label%3DApache&data=02%7C01%7Caharui%40adobe.com%7C77f8dfd71ea64e8ff6e808d5c697eaa3%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633278145970805&sdata=%2Bh4IvrRp38F4HURH65JJ7RRj8WQQZFDOKqb%2BH3Q4TYs%3D&reserved=0
> Flex
>     > SDK 4.16.1&version=4.16.1&os=mac&installerversion=3.3.1&info=Timeout
>     >
>     >
>     > I cant get past the first screen, Flex Version 4.16.1
>     > Air 29
>     > Player 29.0
>     >
>     >
>     >
>     > --
>     > Sent from:
> https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-flex-development.2333347.n4.nabble.com%2F&data=02%7C01%7Caharui%40adobe.com%7C77f8dfd71ea64e8ff6e808d5c697eaa3%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633278145970805&sdata=9ZKYzlh0m5xGXnWDyBOc3aWPCvhN2shl2ACyH9hFS6Y%3D&reserved=0
>     >





--
Sent from: http://apache-flex-development.2333347.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

oharkins
Tried Installing via ant -f install.xml here is my log with a failed build.

check-cache:

download_using_get:
      [get] Getting:
http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To:
/Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/en_US.properties

get-if-not-cached:
      [get] Getting:
http://flex.apache.org/installer/properties/sdk/en_US.properties
      [get] To:
/Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/en_US.properties

check-params:

get-with-no-params:
      [get] Getting:
http://airdownload.adobe.com/air/mac/download/29.0//AdobeAIRSDK.dmg?ts=201805311405
      [get] To:
/Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/in/AdobeAIRSDK.dmg
      [get]
http://airdownload.adobe.com/air/mac/download/29.0//AdobeAIRSDK.dmg?ts=201805311405
permanently moved to
https://airdownload.adobe.com/air/mac/download/29.0/AdobeAIRSDK.dmg?ts=201805311405

BUILD FAILED
/Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:351:
The following error occurred while executing this line:
/Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:371:
The following error occurred while executing this line:
/Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:895:
The following error occurred while executing this line:
/Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:920:
The following error occurred while executing this line:
/Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:927:
The following error occurred while executing this line:
/Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:967:
Redirection detected from http to https. Protocol switch unsafe, not
allowed.



--
Sent from: http://apache-flex-development.2333347.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Alex Harui-2
I updated the AIR 29 to start with HTTPS.  Please try again.

Thanks,
-Alex

On 5/31/18, 1:08 PM, "oharkins" <[hidden email]> wrote:

    Tried Installing via ant -f install.xml here is my log with a failed build.
   
    check-cache:
   
    download_using_get:
          [get] Getting:
    https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apache.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7Caharui%40adobe.com%7C425b7e9656174c1faa6b08d5c7325347%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633941330917025&sdata=YGYqRik8h4bpSxNnPs%2FPzhBAf4YcrOpDYuidBNE47T4%3D&reserved=0
          [get] To:
    /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/en_US.properties
   
    get-if-not-cached:
          [get] Getting:
    https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apache.org%2Finstaller%2Fproperties%2Fsdk%2Fen_US.properties&data=02%7C01%7Caharui%40adobe.com%7C425b7e9656174c1faa6b08d5c7325347%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633941330917025&sdata=YGYqRik8h4bpSxNnPs%2FPzhBAf4YcrOpDYuidBNE47T4%3D&reserved=0
          [get] To:
    /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/en_US.properties
   
    check-params:
   
    get-with-no-params:
          [get] Getting:
    https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fairdownload.adobe.com%2Fair%2Fmac%2Fdownload%2F29.0%2F%2FAdobeAIRSDK.dmg%3Fts%3D201805311405&data=02%7C01%7Caharui%40adobe.com%7C425b7e9656174c1faa6b08d5c7325347%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633941330917025&sdata=SLMfem6kXDSsQCIBrjO1x13mivyOIhv0ga4LK3SBj54%3D&reserved=0
          [get] To:
    /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/in/AdobeAIRSDK.dmg
          [get]
    https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fairdownload.adobe.com%2Fair%2Fmac%2Fdownload%2F29.0%2F%2FAdobeAIRSDK.dmg%3Fts%3D201805311405&data=02%7C01%7Caharui%40adobe.com%7C425b7e9656174c1faa6b08d5c7325347%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633941330917025&sdata=SLMfem6kXDSsQCIBrjO1x13mivyOIhv0ga4LK3SBj54%3D&reserved=0
    permanently moved to
    https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fairdownload.adobe.com%2Fair%2Fmac%2Fdownload%2F29.0%2FAdobeAIRSDK.dmg%3Fts%3D201805311405&data=02%7C01%7Caharui%40adobe.com%7C425b7e9656174c1faa6b08d5c7325347%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633941330917025&sdata=YLAB8NJWoe96f3eE78sPiuoCZ4W4kcM%2BjPSSYfP1ZO0%3D&reserved=0
   
    BUILD FAILED
    /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:351:
    The following error occurred while executing this line:
    /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:371:
    The following error occurred while executing this line:
    /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:895:
    The following error occurred while executing this line:
    /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:920:
    The following error occurred while executing this line:
    /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:927:
    The following error occurred while executing this line:
    /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:967:
    Redirection detected from http to https. Protocol switch unsafe, not
    allowed.
   
   
   
    --
    Sent from: https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-flex-development.2333347.n4.nabble.com%2F&data=02%7C01%7Caharui%40adobe.com%7C425b7e9656174c1faa6b08d5c7325347%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636633941330917025&sdata=Sc533WBHbzbAbPnubhBv9m9b5TCMsL7PADxKmGRpv4Y%3D&reserved=0
   

Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Justin Mclean-5
In reply to this post by oharkins
Hi,

> get-with-no-params:
>      [get] Getting:
> http://airdownload.adobe.com/air/mac/download/29.0//AdobeAIRSDK.dmg?ts=201805311405
>      [get] To:
> /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/in/AdobeAIRSDK.dmg
>      [get]
> http://airdownload.adobe.com/air/mac/download/29.0//AdobeAIRSDK.dmg?ts=201805311405
> permanently moved to
> https://airdownload.adobe.com/air/mac/download/29.0/AdobeAIRSDK.dmg?ts=201805311405

The issue is is that a http URI is being requested and Adobe’s server is returning a 301 saying the file has moved and gives a https URI.

> /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-flex-sdk-4.16.1-bin/installer.xml:967:
> Redirection detected from http to https. Protocol switch unsafe, not allowed.

And the redirection from http to https is not allowed by ant. That issue might be ant version specific.

Hosting the binaries elsewhere is not going o fix this issue. Changing the URL from http: to https: may do.

Here’s the curl output showing what is going on:
curl -v http://airdownload.adobe.com/air/mac/download/29.0//AdobeAIRSDK.dmg
*   Trying 23.9.226.40...
* TCP_NODELAY set
* Connected to airdownload.adobe.com (23.9.226.40) port 80 (#0)
> GET /air/mac/download/29.0//AdobeAIRSDK.dmg HTTP/1.1
> Host: airdownload.adobe.com
> User-Agent: curl/7.54.0
> Accept: */*
>
< HTTP/1.1 301 Moved Permanently
< Server: AkamaiGHost
< Content-Length: 0
< Location: https://airdownload.adobe.com/air/mac/download/29.0/AdobeAIRSDK.dmg
< Date: Thu, 31 May 2018 21:58:35 GMT
< Connection: keep-alive


Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Joel Tan-3
Hi Alex,

As what Justin has explained, it is due to the redirection from http to
https issue, this mean even if I use the order version of the installer
will still having the same problem. Currently I am using 4.16.1 AIR28 for
my application, I can still remain using this version of SDK for awhile, no
hurry to upgrade, you guys can take your time to resolve the issue.

Thanks for all the support.

Joel


On Fri, Jun 1, 2018 at 5:59 AM, Justin Mclean <[hidden email]> wrote:

> Hi,
>
> > get-with-no-params:
> >      [get] Getting:
> > http://airdownload.adobe.com/air/mac/download/29.0//AdobeAIRSDK.dmg?ts=
> 201805311405
> >      [get] To:
> > /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-
> flex-sdk-4.16.1-bin/in/AdobeAIRSDK.dmg
> >      [get]
> > http://airdownload.adobe.com/air/mac/download/29.0//AdobeAIRSDK.dmg?ts=
> 201805311405
> > permanently moved to
> > https://airdownload.adobe.com/air/mac/download/29.0/AdobeAIRSDK.dmg?ts=
> 201805311405
>
> The issue is is that a http URI is being requested and Adobe’s server is
> returning a 301 saying the file has moved and gives a https URI.
>
> > /Users/oharkins/Documents/Adobe/ApachieFlex/test/apache-
> flex-sdk-4.16.1-bin/installer.xml:967:
> > Redirection detected from http to https. Protocol switch unsafe, not
> allowed.
>
> And the redirection from http to https is not allowed by ant. That issue
> might be ant version specific.
>
> Hosting the binaries elsewhere is not going o fix this issue. Changing the
> URL from http: to https: may do.
>
> Here’s the curl output showing what is going on:
> curl -v http://airdownload.adobe.com/air/mac/download/29.0//
> AdobeAIRSDK.dmg
> *   Trying 23.9.226.40...
> * TCP_NODELAY set
> * Connected to airdownload.adobe.com (23.9.226.40) port 80 (#0)
> > GET /air/mac/download/29.0//AdobeAIRSDK.dmg HTTP/1.1
> > Host: airdownload.adobe.com
> > User-Agent: curl/7.54.0
> > Accept: */*
> >
> < HTTP/1.1 301 Moved Permanently
> < Server: AkamaiGHost
> < Content-Length: 0
> < Location: https://airdownload.adobe.com/air/mac/download/29.0/
> AdobeAIRSDK.dmg
> < Date: Thu, 31 May 2018 21:58:35 GMT
> < Connection: keep-alive
>
>
> Thanks,
> Justin
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Justin Mclean
Administrator
Hi,

> As what Justin has explained, it is due to the redirection from http to
> https issue, this mean even if I use the order version of the installer
> will still having the same problem.

Look like Alex has updated that UTL to use https, you might want to try again.

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Joel Tan-3
Hi Justin,

> Look like Alex has updated that UTL to use https, you might want to try
again.
Have tried it but still the same timeout issue, I am using the same version
of installer (3.3.1 Mac) to install, do I need to use the older versions of
installer instead?

Joel

On Fri, Jun 1, 2018 at 6:21 AM, Justin Mclean <[hidden email]>
wrote:

> Hi,
>
> > As what Justin has explained, it is due to the redirection from http to
> > https issue, this mean even if I use the order version of the installer
> > will still having the same problem.
>
> Look like Alex has updated that UTL to use https, you might want to try
> again.
>
> Thanks,
> Justin
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Justin Mclean-5
HI,

> Have tried it but still the same timeout issue, I am using the same version
> of installer (3.3.1 Mac) to install, do I need to use the older versions of
> installer instead?

The old XML config file is probably cached and you’re probably not seeing the new version.

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Alex Harui-2
In reply to this post by Joel Tan-3
Hi Joel,

There are two different issues that have been brought up.  The installer program is required to use a mirror to download the latest release (4.16.1) per Apache policy.  The installer is failing to fetch the mirror information over HTTPS.  We have asked for help from the original developer of our HTTPS handling code.

So, as an alternative until that is fixed, I have suggested folks use Apache Ant.  One user wrote in to say that the Adobe AIR SDK would not download because Ant would not allow a redirection from HTTP to HTTPS, so I just updated the AIR 29 URL we download from to HTTPS so there won't be a switch.  So folks who have tried Apache Ant to install Apache Flex should try again.

But the installer program will not work for Flex 4.16.1 until we find a way to host the release some place without requiring a mirror lookup.  I think Justin's original reply on this thread was not quite right and led to confusion.

So, folks wanting to install Apache Flex 4.16.1 should use Ant for now.  But I think I've made other changes today so that you can use the installer program to Install 4.16.0 and earlier, but you may not be successful using the installer program with these older releases and Adobe AIR 28 and 29.  You may need to use older releases and older Adobe AIR SDKs.

Hopefully we will get this straightened out soon.

Thanks,
-Alex

On 5/31/18, 3:30 PM, "Joel Tan" <[hidden email]> wrote:

    Hi Justin,
   
    > Look like Alex has updated that UTL to use https, you might want to try
    again.
    Have tried it but still the same timeout issue, I am using the same version
    of installer (3.3.1 Mac) to install, do I need to use the older versions of
    installer instead?
   
    Joel
   
    On Fri, Jun 1, 2018 at 6:21 AM, Justin Mclean <[hidden email]>
    wrote:
   
    > Hi,
    >
    > > As what Justin has explained, it is due to the redirection from http to
    > > https issue, this mean even if I use the order version of the installer
    > > will still having the same problem.
    >
    > Look like Alex has updated that UTL to use https, you might want to try
    > again.
    >
    > Thanks,
    > Justin
   

Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Joel Tan-3
Hi Alex,

Noted with thanks!

Joel

On Fri, Jun 1, 2018 at 7:06 AM, Alex Harui <[hidden email]> wrote:

> Hi Joel,
>
> There are two different issues that have been brought up.  The installer
> program is required to use a mirror to download the latest release (4.16.1)
> per Apache policy.  The installer is failing to fetch the mirror
> information over HTTPS.  We have asked for help from the original developer
> of our HTTPS handling code.
>
> So, as an alternative until that is fixed, I have suggested folks use
> Apache Ant.  One user wrote in to say that the Adobe AIR SDK would not
> download because Ant would not allow a redirection from HTTP to HTTPS, so I
> just updated the AIR 29 URL we download from to HTTPS so there won't be a
> switch.  So folks who have tried Apache Ant to install Apache Flex should
> try again.
>
> But the installer program will not work for Flex 4.16.1 until we find a
> way to host the release some place without requiring a mirror lookup.  I
> think Justin's original reply on this thread was not quite right and led to
> confusion.
>
> So, folks wanting to install Apache Flex 4.16.1 should use Ant for now.
> But I think I've made other changes today so that you can use the installer
> program to Install 4.16.0 and earlier, but you may not be successful using
> the installer program with these older releases and Adobe AIR 28 and 29.
> You may need to use older releases and older Adobe AIR SDKs.
>
> Hopefully we will get this straightened out soon.
>
> Thanks,
> -Alex
>
> On 5/31/18, 3:30 PM, "Joel Tan" <[hidden email]> wrote:
>
>     Hi Justin,
>
>     > Look like Alex has updated that UTL to use https, you might want to
> try
>     again.
>     Have tried it but still the same timeout issue, I am using the same
> version
>     of installer (3.3.1 Mac) to install, do I need to use the older
> versions of
>     installer instead?
>
>     Joel
>
>     On Fri, Jun 1, 2018 at 6:21 AM, Justin Mclean <
> [hidden email]>
>     wrote:
>
>     > Hi,
>     >
>     > > As what Justin has explained, it is due to the redirection from
> http to
>     > > https issue, this mean even if I use the order version of the
> installer
>     > > will still having the same problem.
>     >
>     > Look like Alex has updated that UTL to use https, you might want to
> try
>     > again.
>     >
>     > Thanks,
>     > Justin
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Justin Mclean-5
In reply to this post by Alex Harui-2
Hi,

> There are two different issues that have been brought up.  The installer program is required to use a mirror to download the latest release (4.16.1) per Apache policy.  The installer is failing to fetch the mirror information over HTTPS.  We have asked for help from the original developer of our HTTPS handling code.

I don’t believe this is only an AIR HTTPS issue.

Try:
curl -v http://apache.melbourneitmirror.net/flex/4.16.1/binaries/apache-flex-sdk-installer-config.xml

(and you see it works)

But:
curl -v https://apache.melbourneitmirror.net/flex/4.16.1/binaries/apache-flex-sdk-installer-config.xml

Will fail with:

*   Trying 202.124.241.168...
* TCP_NODELAY set
* Connected to apache.melbourneitmirror.net (202.124.241.168) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/cert.pem
  CApath: none
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* TLSv1.2 (IN), TLS alert, Server hello (2):
* error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure
* stopped the pause stream!
* Closing connection 0
curl: (35) error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

So wouldn't the easy fix be just get the config file over http?

Thanks,
Justin

Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Justin Mclean
Administrator
In reply to this post by Alex Harui-2
Hi,

> There are two different issues that have been brought up.  The installer program is required to use a mirror to download the latest release (4.16.1) per Apache policy.  The installer is failing to fetch the mirror information over HTTPS.  We have asked for help from the original developer of our HTTPS handling code.

The http call to the  single mirror CGI script to get the mirror information works. It’s the https call to the mirror to get the XML installer config file that is failing.

Thanks,.
Justin

Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Justin Mclean
Administrator
Hi,

>  It’s the https call to the mirror to get the XML installer config file that is failing.

And it could be failing for one of two reasons,  Which I don't think has been 100% determined,
1. The page structure has changed and it failing to correctly parse the mirror URL out of the page so the URL it manufactures times out
2. It's a https issues

The first option seem more likely to me. Has anyone looked at that?

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Justin Mclean
Administrator
Hi,

> 1. The page structure has changed and it failing to correctly parse the mirror URL out of the page so the URL it manufactures times out

And Ive confirmed (in the debugger) that exactly what is happening. This code below in MirrorURLUtil.as is no longer parsing the correct mirror name out of the content returned.

var result:String = _internetUtil.result;
                       
_mirrorURL = (result.search("<p>") != -1) ?
        result.substring(3, result.length - 4) :
        result;

Issue being I think that the cgi script is returning full page of HTML which is not what this code expects.

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

Re: Installer is Timing Out.

Alex Harui-2
Hi Justin,

That doesn't sound like what I saw when I debugged into it last week, but if you are right, then it sounds like you can prepare a fix for it.

-Alex

On 5/31/18, 7:36 PM, "Justin Mclean" <[hidden email]> wrote:

    Hi,
   
    > 1. The page structure has changed and it failing to correctly parse the mirror URL out of the page so the URL it manufactures times out
   
    And Ive confirmed (in the debugger) that exactly what is happening. This code below in MirrorURLUtil.as is no longer parsing the correct mirror name out of the content returned.
   
    var result:String = _internetUtil.result;
   
    _mirrorURL = (result.search("<p>") != -1) ?
    result.substring(3, result.length - 4) :
    result;
   
    Issue being I think that the cgi script is returning full page of HTML which is not what this code expects.
   
    Thanks,
    Justin

12345