[LAST CALL] Apache Flex SDK Installer 3.3

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

[LAST CALL] Apache Flex SDK Installer 3.3

piotrz
Hi Folks,

This is the official last call for any and all features, fixes and
other changes that need to be made to the installer to
get it ready to release.

The last successful build can be found here [1]. There is only one fix for
the installer [2]. You can test it by trying to download Nightly build of
Flex SDK with Adobe Air greater than 23 on Windows.

I will cut the release branch if there will be no objections. I will need
help also with putting the RC1 somewhere for the VOTE thread purpose.

[1]
http://apacheflexbuild.cloudapp.net:8080/job/flex-utilities_installer/lastSuccessfulBuild/
[2] https://issues.apache.org/jira/browse/FLEX-35295

Thanks,
Piotr
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

Justin Mclean-5
Hi,

Id there a source release anyway we can check I’m not seeing one at builds.apacge.org - but could of missed it.

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

piotrz
Hi,

I don't understand. Under the link which I provided you don't see sources
packaged to zip?

Thanks, Piotr

On Fri, Nov 3, 2017, 08:20 Justin Mclean <[hidden email]> wrote:

> Hi,
>
> Id there a source release anyway we can check I’m not seeing one at
> builds.apacge.org - but could of missed it.
>
> Thanks,
> Justin
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

Justin Mclean
Administrator
Hi,

> I don't understand. Under the link which I provided you don't see sources
> packaged to zip?

Sorry the link you provided was being unresponsive for me and I thought we also have a build on Apache’s  build servers but was unable to find it.

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

Justin Mclean
Administrator
In reply to this post by piotrz
Hi,

I took a quick look and looks like there’s a couple of things that need to be fixed:
 - there are things bundled that perhaps should’t be i.e. ant_on_air/tests/temp
 - NOTICE has wrong year

I’m currently travelling and may not be able to look at it again for several days.

Thanks,
Justin
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

piotrz
Hi,

Both issue has been fixed. You can check sources [1].

[1]
http://apacheflexbuild.cloudapp.net:8080/job/flex-utilities_installer/1335/

Thanks, Piotr

2017-11-03 17:19 GMT+01:00 Justin Mclean <[hidden email]>:

> Hi,
>
> I took a quick look and looks like there’s a couple of things that need to
> be fixed:
>  - there are things bundled that perhaps should’t be i.e.
> ant_on_air/tests/temp
>  - NOTICE has wrong year
>
> I’m currently travelling and may not be able to look at it again for
> several days.
>
> Thanks,
> Justin




--

Piotr Zarzycki

mobile: +48 880 859 557
skype: zarzycki10

LinkedIn: http://www.linkedin.com/piotrzarzycki
<https://pl.linkedin.com/in/piotr-zarzycki-92a53552>

GitHub: https://github.com/piotrzarzycki21
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

AmigaAbattoir
Just subscribed to post that I found an issue using the Flex 3.2 installer on
a new Mac laptop with OS 10.13. I filed a Jira ticket[1]. Just like iOS, for
Mac 10.13 it seems like if your application makes HTTP calls, you need to
include in the Info.plist the NSAppTransportSecurity/NSAllowsArbitraryLoads
keys.  

[1]
https://issues.apache.org/jira/browse/FLEX-35365



--
Sent from: http://apache-flex-development.2333347.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

piotrz
Hi,

I have I think so same Mac version - need to confirm and didn't have such
issue. Could you try Installer 3.3 and let us know whether you experience
same issue.

Piotr

On Sat, Nov 4, 2017, 03:42 AmigaAbattoir <[hidden email]>
wrote:

> Just subscribed to post that I found an issue using the Flex 3.2 installer
> on
> a new Mac laptop with OS 10.13. I filed a Jira ticket[1]. Just like iOS,
> for
> Mac 10.13 it seems like if your application makes HTTP calls, you need to
> include in the Info.plist the NSAppTransportSecurity/NSAllowsArbitraryLoads
> keys.
>
> [1]
> https://issues.apache.org/jira/browse/FLEX-35365
>
>
>
> --
> Sent from: http://apache-flex-development.2333347.n4.nabble.com/
>
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

Alex Harui-2
I updated and ran the approval script.  Things look ok to me.

Thanks,
-Alex

On 11/3/17, 7:56 PM, "Piotr Zarzycki" <[hidden email]> wrote:

>Hi,
>
>I have I think so same Mac version - need to confirm and didn't have such
>issue. Could you try Installer 3.3 and let us know whether you experience
>same issue.
>
>Piotr
>
>On Sat, Nov 4, 2017, 03:42 AmigaAbattoir <[hidden email]>
>wrote:
>
>> Just subscribed to post that I found an issue using the Flex 3.2
>>installer
>> on
>> a new Mac laptop with OS 10.13. I filed a Jira ticket[1]. Just like iOS,
>> for
>> Mac 10.13 it seems like if your application makes HTTP calls, you need
>>to
>> include in the Info.plist the
>>NSAppTransportSecurity/NSAllowsArbitraryLoads
>> keys.
>>
>> [1]
>>
>>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fissues.a
>>pache.org%2Fjira%2Fbrowse%2FFLEX-35365&data=02%7C01%7C%7Ce40e744a72c040e4
>>524508d5232fc22c%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C63645361041
>>0738788&sdata=nM43AR6Zy5xzgEvlKjPa7HqooLN9DE%2FXyRB2uRD75os%3D&reserved=0
>>
>>
>>
>> --
>> Sent from:
>>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-fl
>>ex-development.2333347.n4.nabble.com%2F&data=02%7C01%7C%7Ce40e744a72c040e
>>4524508d5232fc22c%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C6364536104
>>10738788&sdata=Ykp05LYuJ2y2hos3FCLE4L6XkmU%2FHAuf3GoUeEGScUg%3D&reserved=
>>0
>>

Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

piotrz
Hi Alex,

Thanks for the help. The next step for me is to create RC, where I can
upload it ? Is there any instruction ?

Piotr

2017-11-04 7:43 GMT+01:00 Alex Harui <[hidden email]>:

> I updated and ran the approval script.  Things look ok to me.
>
> Thanks,
> -Alex
>
> On 11/3/17, 7:56 PM, "Piotr Zarzycki" <[hidden email]> wrote:
>
> >Hi,
> >
> >I have I think so same Mac version - need to confirm and didn't have such
> >issue. Could you try Installer 3.3 and let us know whether you experience
> >same issue.
> >
> >Piotr
> >
> >On Sat, Nov 4, 2017, 03:42 AmigaAbattoir <[hidden email]>
> >wrote:
> >
> >> Just subscribed to post that I found an issue using the Flex 3.2
> >>installer
> >> on
> >> a new Mac laptop with OS 10.13. I filed a Jira ticket[1]. Just like iOS,
> >> for
> >> Mac 10.13 it seems like if your application makes HTTP calls, you need
> >>to
> >> include in the Info.plist the
> >>NSAppTransportSecurity/NSAllowsArbitraryLoads
> >> keys.
> >>
> >> [1]
> >>
> >>https://na01.safelinks.protection.outlook.com/?url=
> https%3A%2F%2Fissues.a
> >>pache.org%2Fjira%2Fbrowse%2FFLEX-35365&data=02%7C01%7C%
> 7Ce40e744a72c040e4
> >>524508d5232fc22c%7Cfa7b1b5a7b34438794aed2c178de
> cee1%7C0%7C0%7C63645361041
> >>0738788&sdata=nM43AR6Zy5xzgEvlKjPa7HqooLN9DE
> %2FXyRB2uRD75os%3D&reserved=0
> >>
> >>
> >>
> >> --
> >> Sent from:
> >>https://na01.safelinks.protection.outlook.com/?url=
> http%3A%2F%2Fapache-fl
> >>ex-development.2333347.n4.nabble.com%2F&data=02%7C01%7C%
> 7Ce40e744a72c040e
> >>4524508d5232fc22c%7Cfa7b1b5a7b34438794aed2c178de
> cee1%7C0%7C0%7C6364536104
> >>10738788&sdata=Ykp05LYuJ2y2hos3FCLE4L6XkmU%
> 2FHAuf3GoUeEGScUg%3D&reserved=
> >>0
> >>
>
>


--

Piotr Zarzycki

mobile: +48 880 859 557
skype: zarzycki10

LinkedIn: http://www.linkedin.com/piotrzarzycki
<https://pl.linkedin.com/in/piotr-zarzycki-92a53552>

GitHub: https://github.com/piotrzarzycki21
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

Alex Harui-2
Hi Piotr,

There are Ant scripts in each repo called releasecandidate.xml.  IMO, it
would be great if you tried them and helped get them to work for you, so
it becomes easier for other release managers to cut releases.  I've used
them for all releases I've managed recently.

There are also some instructions in the wiki
https://cwiki.apache.org/confluence/display/FLEX/Release+Manager+and+Releas
e+Voter+Ant+Scripts

HTH,
-Alex

On 11/4/17, 2:29 AM, "Piotr Zarzycki" <[hidden email]> wrote:

>Hi Alex,
>
>Thanks for the help. The next step for me is to create RC, where I can
>upload it ? Is there any instruction ?
>
>Piotr
>
>2017-11-04 7:43 GMT+01:00 Alex Harui <[hidden email]>:
>
>> I updated and ran the approval script.  Things look ok to me.
>>
>> Thanks,
>> -Alex
>>
>> On 11/3/17, 7:56 PM, "Piotr Zarzycki" <[hidden email]> wrote:
>>
>> >Hi,
>> >
>> >I have I think so same Mac version - need to confirm and didn't have
>>such
>> >issue. Could you try Installer 3.3 and let us know whether you
>>experience
>> >same issue.
>> >
>> >Piotr
>> >
>> >On Sat, Nov 4, 2017, 03:42 AmigaAbattoir
>><[hidden email]>
>> >wrote:
>> >
>> >> Just subscribed to post that I found an issue using the Flex 3.2
>> >>installer
>> >> on
>> >> a new Mac laptop with OS 10.13. I filed a Jira ticket[1]. Just like
>>iOS,
>> >> for
>> >> Mac 10.13 it seems like if your application makes HTTP calls, you
>>need
>> >>to
>> >> include in the Info.plist the
>> >>NSAppTransportSecurity/NSAllowsArbitraryLoads
>> >> keys.
>> >>
>> >> [1]
>> >>
>> >>https://na01.safelinks.protection.outlook.com/?url=
>> https%3A%2F%2Fissues.a
>> >>pache.org%2Fjira%2Fbrowse%2FFLEX-35365&data=02%7C01%7C%
>> 7Ce40e744a72c040e4
>> >>524508d5232fc22c%7Cfa7b1b5a7b34438794aed2c178de
>> cee1%7C0%7C0%7C63645361041
>> >>0738788&sdata=nM43AR6Zy5xzgEvlKjPa7HqooLN9DE
>> %2FXyRB2uRD75os%3D&reserved=0
>> >>
>> >>
>> >>
>> >> --
>> >> Sent from:
>> >>https://na01.safelinks.protection.outlook.com/?url=
>> http%3A%2F%2Fapache-fl
>> >>ex-development.2333347.n4.nabble.com%2F&data=02%7C01%7C%
>> 7Ce40e744a72c040e
>> >>4524508d5232fc22c%7Cfa7b1b5a7b34438794aed2c178de
>> cee1%7C0%7C0%7C6364536104
>> >>10738788&sdata=Ykp05LYuJ2y2hos3FCLE4L6XkmU%
>> 2FHAuf3GoUeEGScUg%3D&reserved=
>> >>0
>> >>
>>
>>
>
>
>--
>
>Piotr Zarzycki
>
>mobile: +48 880 859 557
>skype: zarzycki10
>
>LinkedIn:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.linked
>in.com%2Fpiotrzarzycki&data=02%7C01%7C%7C7e7d91b23c9142cec54208d523669065%
>7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636453845782891772&sdata=Um0O
>%2Fu%2BfP1u0Yw%2FU0YNffa8qqx0pwmFy1291ulS7l60%3D&reserved=0
><https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fpl.linke
>din.com%2Fin%2Fpiotr-zarzycki-92a53552&data=02%7C01%7C%7C7e7d91b23c9142cec
>54208d523669065%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C6364538457828
>91772&sdata=9BAxMzkqMdNSe%2FEQdCM1gz%2FF46IutjDRr%2B1R9FrjLGE%3D&reserved=
>0>
>
>GitHub:
>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.co
>m%2Fpiotrzarzycki21&data=02%7C01%7C%7C7e7d91b23c9142cec54208d523669065%7Cf
>a7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636453845782891772&sdata=jkz5IY8
>wRt6KtnMVs7pn3ZAMMUdafvIilCV3kYLW%2FCI%3D&reserved=0

Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

AmigaAbattoir
In reply to this post by piotrz
I tried using the instructions for building the installer with ANT and used
AIR 4.0. With that version of AIR, it fails on OS 10.13.

When I ended up building with AIR 27 it works on 10.13, which according to
the AIR 27 release notes[1] states "With AIR SDK 27, all AIR applications
built for macOS will automatically have the NSAllowsArbitraryLoads key set
as true in their info.plist file"

Do you think the README should be updated with that information?

[1]
https://forums.adobe.com/thread/2384472


piotrz wrote
> Hi,
>
> I have I think so same Mac version - need to confirm and didn't have such
> issue. Could you try Installer 3.3 and let us know whether you experience
> same issue.
>
> Piotr





--
Sent from: http://apache-flex-development.2333347.n4.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

piotrz
Hi Christopher,

You have said in jira comments that if installer is being build with Air 27
everything should work fine. I have build new version of installer with AIR
25 and Flex 4.16. It worked perfectly fine on my Mac Sierra. I will try to
build version with signed keys and see what happen.

Thanks, Piotr


2017-11-05 17:05 GMT+01:00 AmigaAbattoir <[hidden email]>:

> I tried using the instructions for building the installer with ANT and used
> AIR 4.0. With that version of AIR, it fails on OS 10.13.
>
> When I ended up building with AIR 27 it works on 10.13, which according to
> the AIR 27 release notes[1] states "With AIR SDK 27, all AIR applications
> built for macOS will automatically have the NSAllowsArbitraryLoads key set
> as true in their info.plist file"
>
> Do you think the README should be updated with that information?
>
> [1]
> https://forums.adobe.com/thread/2384472
>
>
> piotrz wrote
> > Hi,
> >
> > I have I think so same Mac version - need to confirm and didn't have such
> > issue. Could you try Installer 3.3 and let us know whether you experience
> > same issue.
> >
> > Piotr
>
>
>
>
>
> --
> Sent from: http://apache-flex-development.2333347.n4.nabble.com/
>



--

Piotr Zarzycki

Patreon: *https://www.patreon.com/piotrzarzycki
<https://www.patreon.com/piotrzarzycki>*
Reply | Threaded
Open this post in threaded view
|

Re: [LAST CALL] Apache Flex SDK Installer 3.3

AmigaAbattoir
Ah, that's the problem. Sierra is 10.12, which I have on my desktop and the
installer worked fine with either version of AIR that I built with.

On my laptop, I'm running 10.13.1 which came out this September and is call
"High Sierra". Only the installer built with AIR 27 worked on the laptop
because of the App Transport Security setting in this version of macOS.



--
Sent from: http://apache-flex-development.2333347.n4.nabble.com/