Moonshine 1.4.0 Release

classic Classic list List threaded Threaded
19 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Moonshine 1.4.0 Release

JoelProminic
I am pleased to announce that Moonshine 1.4.0 has been released at http://moonshine-ide.com/ and on the App Store.

This release was focused mostly on adding some more common IDE features, including:
- Command-Click to go to the definition for a variable, function, or class
- View code problems in a list or by in-line highlighting
- Find all references for a variable, function, or class.
- List and search all definitions in a file or project


We also added code-completion support for FlexJS 0.8.0 nightly builds.

Let us know if you encounter any issues with the update.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

Alex Harui-2
Congratulations!  I hope to try it soon.

-Alex

On 5/15/17, 1:30 PM, "JoelProminic" <[hidden email]> wrote:

>I am pleased to announce that Moonshine 1.4.0 has been released at
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmoonshine-
>ide.com%2F&data=02%7C01%7C%7C5aa22741f72247e3dd8508d49bd322bb%7Cfa7b1b5a7b
>34438794aed2c178decee1%7C0%7C0%7C636304778500172479&sdata=xZpUR5mVEUL1JHnL
>56ZoL6cXvkaWNZ5mOPXuDwXE8VA%3D&reserved=0 and on the App Store.
>
>This release was focused mostly on adding some more common IDE features,
>including:
>- Command-Click to go to the definition for a variable, function, or class
>- View code problems in a list or by in-line highlighting
>- Find all references for a variable, function, or class.
>- List and search all definitions in a file or project
>
>
>We also added code-completion support for FlexJS 0.8.0 nightly builds.
>
>Let us know if you encounter any issues with the update.
>
>
>
>
>--
>View this message in context:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-fle
>x-development.2333347.n4.nabble.com%2FMoonshine-1-4-0-Release-tp61632.html
>&data=02%7C01%7C%7C5aa22741f72247e3dd8508d49bd322bb%7Cfa7b1b5a7b34438794ae
>d2c178decee1%7C0%7C0%7C636304778500172479&sdata=IzUIbMm1MUmcB%2BsSt1h22OG1
>A%2FG6iWTC2VDL3e5uehw%3D&reserved=0
>Sent from the Apache Flex Development mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

yishayw
In reply to this post by JoelProminic
I tried it, but the window title is out of the screen, so I can't see the menus, expand, minimize, etc. Using windows 10. See png.

Resolution 3200x1800, scale factor 250%.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

Andrew Wetmore
I downloaded it, but my anti-spam program (avast!) has put it in quarantine
while it investigates the .exe file. I have not had the problem with past
versions.

On Tue, May 16, 2017 at 10:56 AM, yishayw <[hidden email]> wrote:

> I tried it, but the window title is out of the screen, so I can't see the
> menus, expand, minimize, etc. Using windows 10. See png.
>
> Resolution 3200x1800, scale factor 250%.
>
> <http://apache-flex-development.2333347.n4.nabble.
> com/file/n61641/Capture.jpg>
>
>
>
> --
> View this message in context: http://apache-flex-
> development.2333347.n4.nabble.com/Moonshine-1-4-0-Release-
> tp61632p61641.html
> Sent from the Apache Flex Development mailing list archive at Nabble.com.
>



--
Andrew Wetmore

http://cottage14.blogspot.com/
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

yishayw
In reply to this post by JoelProminic
Also, code completion opens a small callout, but can't see content.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

Josh Tynjala
All those errors in the editor make me think the missing code completion is
just a side effect of a larger issue. What kind of errors are reported in
the Problems view?

- Josh

On May 16, 2017 7:19 AM, "yishayw" <[hidden email]> wrote:

> Also, code completion opens a small callout, but can't see content.
>
> <http://apache-flex-development.2333347.n4.nabble.
> com/file/n61644/Untitled.png>
>
>
>
> --
> View this message in context: http://apache-flex-
> development.2333347.n4.nabble.com/Moonshine-1-4-0-Release-
> tp61632p61644.html
> Sent from the Apache Flex Development mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

Peter Ent-2
In reply to this post by JoelProminic
On Mac macOS Sierra: When I start this new version of Moonshine, I get a
dialog that tells me that due to an Apple sandbox issue, my Apache Flex
and Apache FlexJS SDKs must be located in the Downloads folder. OK, fine,
so I click on the button that takes me to a Moonshine downloads page, but
there is only a download for Moonshine
(http://moonshine-ide.com/moonshine-app-store-helper/) Helper. Thinking
that is probably it (I was actually expecting to do to the Apache
Flex/FlexJS page to get the SDKs), I downloaded the package and launched
it.

That did "something" (not sure what) and then offered to delete itself,
which I did. This left my Downloads folder in its original condition
(which is currently empty).

So I'm not really sure this part of the set up worked.

Regards,
Peter Ent
Adobe Systems/Apache Flex Project

On 5/15/17, 4:30 PM, "JoelProminic" <[hidden email]> wrote:

>I am pleased to announce that Moonshine 1.4.0 has been released at
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fmoonshine-
>ide.com%2F&data=02%7C01%7C%7Cf4c257aead604dcde0ad08d49bd320ee%7Cfa7b1b5a7b
>34438794aed2c178decee1%7C0%7C0%7C636304778468882690&sdata=wMoLsDsaRFuRc6wa
>ahe84LzbdNBl%2F598mEJykwg5w5E%3D&reserved=0 and on the App Store.
>
>This release was focused mostly on adding some more common IDE features,
>including:
>- Command-Click to go to the definition for a variable, function, or class
>- View code problems in a list or by in-line highlighting
>- Find all references for a variable, function, or class.
>- List and search all definitions in a file or project
>
>
>We also added code-completion support for FlexJS 0.8.0 nightly builds.
>
>Let us know if you encounter any issues with the update.
>
>
>
>
>--
>View this message in context:
>https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fapache-fle
>x-development.2333347.n4.nabble.com%2FMoonshine-1-4-0-Release-tp61632.html
>&data=02%7C01%7C%7Cf4c257aead604dcde0ad08d49bd320ee%7Cfa7b1b5a7b34438794ae
>d2c178decee1%7C0%7C0%7C636304778468882690&sdata=P3PuvUqVioWi6R6q%2B0pTIOWm
>XEX1%2B2HtyKotoain41Y%3D&reserved=0
>Sent from the Apache Flex Development mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

yishayw
In reply to this post by Josh Tynjala
It's difficult for me to find the problems view in the current state. Piotrz will be here later so I'll see if he has insights. Full screen view isn't working (mouse pointer events are off). Thanks.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

piotrz
In reply to this post by Josh Tynjala
Hi Josh,

I know that you coming today. Maybe we can meet and show you that issue with Moonshine? Let me know here on off the list. I'm controlling email. :)

Thanks,
Piotr
Apache Flex PMC
piotrzarzycki21@gmail.com
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

JoelProminic
In reply to this post by yishayw
yishayw,

It seems that the resolution problem is caused because the default window height is too tall for your monitor after the scale is applied.   We will look into making Moonshine more DPI-aware.  In the meantime, you can try using the WindowsKey-Up command to maximize the application.

I was not able to reproduce the mouse event issues you reported Fullscreen mode (but I wasn't able to test with scaling).

For the error popup, please check the following:
- In File->Settings->MXMLC Compiler Plugin, check that the default SDK is set to an appropriate (0.7.0 or 0.8.0) FlexJS SDK.
- Did you define a Java SDK for Moonshine?  If not, you should be prompted when restarting the application.
- As Josh suggested, check View->Problems View to see if you can find more information about the error messages.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

JoelProminic
In reply to this post by Peter Ent-2
The Moonshine App Store Helper application is supposed to launch automatically after the installer completes, but it seems that this is currently broken.  For now, please launch the application manually.

This application will download Flex 4.15.0, FlexJS 0.7.0, and Ant 1.10.1 to ~/Downloads/Moonshine SDKs, so that they can be automatically configured by Moonshine.   If you wish to use copies of the SDKs that you downloaded yourself, they will need to be placed in ~/Downloads because of a sandbox limitation.

Peter Ent-2 wrote
On Mac macOS Sierra: When I start this new version of Moonshine, I get a
dialog that tells me that due to an Apple sandbox issue, my Apache Flex
and Apache FlexJS SDKs must be located in the Downloads folder. OK, fine,
so I click on the button that takes me to a Moonshine downloads page, but
there is only a download for Moonshine
(http://moonshine-ide.com/moonshine-app-store-helper/) Helper. Thinking
that is probably it (I was actually expecting to do to the Apache
Flex/FlexJS page to get the SDKs), I downloaded the package and launched
it.

That did "something" (not sure what) and then offered to delete itself,
which I did. This left my Downloads folder in its original condition
(which is currently empty).

So I'm not really sure this part of the set up worked.

Regards,
Peter Ent
Adobe Systems/Apache Flex Project
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

Josh Tynjala
In reply to this post by piotrz
Hi Piotr,

I'll be going to registration right away tomorrow at 8am to pick up my
badge. Then, I'll be available for a couple of hours, if you can meet me
somewhere. Let me know!

- Josh


On May 16, 2017 4:59 PM, "piotrz" <[hidden email]> wrote:

> Hi Josh,
>
> I know that you coming today. Maybe we can meet and show you that issue
> with
> Moonshine? Let me know here on off the list. I'm controlling email. :)
>
> Thanks,
> Piotr
>
>
>
> -----
> Apache Flex PMC
> [hidden email]
> --
> View this message in context: http://apache-flex-development
> .2333347.n4.nabble.com/Moonshine-1-4-0-Release-tp61632p61658.html
> Sent from the Apache Flex Development mailing list archive at Nabble.com.
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

Nemi
In reply to this post by JoelProminic
It asks me to set/fix FlexJS SDK, but I already set it:
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

Nemi
And can't click on white X to close it, so one must click "Continue without Code Completition" although it is properly set in SDK list...
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

Nemi
Oh, and now "Continue without Code Completition" button doesn't work. Now I am trapped, can't remove that alert/popup window.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

Nemi
In reply to this post by JoelProminic
On your website, "Latest Version" button is not working, or it is not a button? It is confusing.
If it is not a button, make it not look like button near by.
If it is a button, why don't you link it to latest win or mac, like links below?


Also, grammar thing, but it matters, why uppercase for "... Version", "... Notes", "... Download" ?
English and German are not my native language, but as far as I know, only in German language one writes nouns always with first letter uppercase (capitalization).
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

Andrew Wetmore
Joel, I sent you a private email offering to do an edit review of the
website. There are a lot of little errors of grammar, capitalization, and
word choice. I work as a freelance editor but I am offering this for free
as my contribution to your estimable project.

a

On Fri, May 19, 2017 at 1:53 PM, Nemi <[hidden email]> wrote:

> On your website, "Latest Version" button is not working, or it is not a
> button? It is confusing.
> If it is not a button, make it not look like button near by.
> If it is a button, why don't you link it to latest win or mac, like links
> below?
> <http://apache-flex-development.2333347.n4.nabble.
> com/file/n61693/screenshot_b538edafe7d04ff788a46901fe5a1e9b.png>
>
> Also, grammar thing, but it matters, why uppercase for "... Version", "...
> Notes", "... Download" ?
> English and German are not my native language, but as far as I know, only
> in
> German language one writes nouns always with first letter uppercase
> (capitalization).
>
>
>
> --
> View this message in context: http://apache-flex-
> development.2333347.n4.nabble.com/Moonshine-1-4-0-Release-
> tp61632p61693.html
> Sent from the Apache Flex Development mailing list archive at Nabble.com.
>



--
Andrew Wetmore

http://cottage14.blogspot.com/
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

JoelProminic
In reply to this post by Nemi
Nemi wrote
It asks me to set/fix FlexJS SDK, but I already set it:

---

And can't click on white X to close it, so one must click "Continue without Code Completition" although it is properly set in SDK list...

---

Oh, and now "Continue without Code Completition" button doesn't work. Now I am trapped, can't remove that alert/popup window.
We are already working on improving the setup process for Windows Moonshine, so this shouldn't be a problem in the next release.

In my test, I was able to click "Continue without Code Completion" after first defining the SDK.  Then I needed to set a default SDK in the settings interface before Moonshine was properly configured.  I'm not sure why the other buttons stopped working for you - I was not able to reproduce this.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Moonshine 1.4.0 Release

JoelProminic
In reply to this post by Nemi
Nemi wrote
On your website, "Latest Version" button is not working, or it is not a button? It is confusing.
If it is not a button, make it not look like button near by.
If it is a button, why don't you link it to latest win or mac, like links below?


Also, grammar thing, but it matters, why uppercase for "... Version", "... Notes", "... Download" ?
English and German are not my native language, but as far as I know, only in German language one writes nouns always with first letter uppercase (capitalization).

The "Latest Version" button is actually a tab.  You can click on "Archived Versions" to change the link list, and "Latest Version" to change back.  I agree that this is a confusing design, though, so we'll look into fixing it.


Thanks for the offer, Andrew, I'll respond privately.
Loading...