OSMF download fails when running 'ant'

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

OSMF download fails when running 'ant'

Erik de Bruin
Hi,

When I run 'ant' on a fresh copy of the Flex SDK repo, I get the following
error:

[error]
download-osmf-swc:
      [get] Getting:
https://sourceforge.net/adobe/flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw
      [get] To: /Users/erik/Desktop/royale/flex-sdk/in/osmf.swc
      [get] Error getting
https://sourceforge.net/adobe/flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw
to /Users/erik/Desktop/royale/flex-sdk/in/osmf.swc

double-check-file:
     [echo] Need file: ${still_no_file}

get-from-cache-if-needed:

fail-if-not-found:

BUILD FAILED
/Users/erik/Desktop/royale/flex-sdk/build.xml:157: The following error
occurred while executing this line:
/Users/erik/Desktop/royale/flex-sdk/frameworks/build.xml:100: The following
error occurred while executing this line:
/Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:105: The
following error occurred while executing this line:
/Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:117: The
following error occurred while executing this line:
/Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:422: osmf.swc
could not be downloaded or found in cache
[/error]

I think I remember this happening way back when as well, but I don't
remember the workaround/fix. Help?

Thanks,

EdB



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl
Reply | Threaded
Open this post in threaded view
|

Re: OSMF download fails when running 'ant'

Erik de Bruin
When I got to sourceforge directly, I see the download link as:

https://sourceforge.net/adobe/flexsdk/code/4/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw

Which is different from the one in the build script:

https://sourceforge.net/adobe/flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw

I hesitate to change the URL in the build script as I don't know if it
changed at sourceforge or if the link in the script is a workaround for
e.g. a redirect at the source when running on the command line?

Thanks,

EdB



On Thu, Sep 28, 2017 at 2:49 PM, Erik de Bruin <[hidden email]> wrote:

> Hi,
>
> When I run 'ant' on a fresh copy of the Flex SDK repo, I get the following
> error:
>
> [error]
> download-osmf-swc:
>       [get] Getting: https://sourceforge.net/adobe/
> flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw
>       [get] To: /Users/erik/Desktop/royale/flex-sdk/in/osmf.swc
>       [get] Error getting https://sourceforge.net/adobe/
> flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw to
> /Users/erik/Desktop/royale/flex-sdk/in/osmf.swc
>
> double-check-file:
>      [echo] Need file: ${still_no_file}
>
> get-from-cache-if-needed:
>
> fail-if-not-found:
>
> BUILD FAILED
> /Users/erik/Desktop/royale/flex-sdk/build.xml:157: The following error
> occurred while executing this line:
> /Users/erik/Desktop/royale/flex-sdk/frameworks/build.xml:100: The
> following error occurred while executing this line:
> /Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:105: The
> following error occurred while executing this line:
> /Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:117: The
> following error occurred while executing this line:
> /Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:422:
> osmf.swc could not be downloaded or found in cache
> [/error]
>
> I think I remember this happening way back when as well, but I don't
> remember the workaround/fix. Help?
>
> Thanks,
>
> EdB
>
>
>
> --
> Ix Multimedia Software
>
> Jan Luykenstraat 27
> 3521 VB Utrecht
>
> T. 06-51952295 <06%2051952295>
> I. www.ixsoftware.nl
>



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl
Reply | Threaded
Open this post in threaded view
|

Re: OSMF download fails when running 'ant'

Alex Harui-2
That is a problem, but for Royale, we should stop requiring the flex-sdk
repo and just use Apache Flex release bits.

My 2 cents,
-Alex

On 9/28/17, 5:53 AM, "Erik de Bruin" <[hidden email]> wrote:

>When I got to sourceforge directly, I see the download link as:
>
>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fsourcefor
>ge.net%2Fadobe%2Fflexsdk%2Fcode%2F4%2Ftree%2Ftrunk%2Fframeworks%2Flibs%2FO
>SMF2_0.swc%3Fformat%3Draw&data=02%7C01%7C%7C42c429a4a4cc4f45da1a08d506700a
>ca%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636422000644802646&sdata=Y
>ptNAOXosiIpC6d6uLJ1iQkv3HQk%2F8661sq1z3iR%2BwA%3D&reserved=0
>
>Which is different from the one in the build script:
>
>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fsourcefor
>ge.net%2Fadobe%2Fflexsdk%2Fcode%2FHEAD%2Ftree%2Ftrunk%2Fframeworks%2Flibs%
>2FOSMF2_0.swc%3Fformat%3Draw&data=02%7C01%7C%7C42c429a4a4cc4f45da1a08d5067
>00aca%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636422000644802646&sdat
>a=p0OyMm1pUCKRuDSZfnFuaPkpl4pDV159KqpXORJNWrI%3D&reserved=0
>
>I hesitate to change the URL in the build script as I don't know if it
>changed at sourceforge or if the link in the script is a workaround for
>e.g. a redirect at the source when running on the command line?
>
>Thanks,
>
>EdB
>
>
>
>On Thu, Sep 28, 2017 at 2:49 PM, Erik de Bruin <[hidden email]> wrote:
>
>> Hi,
>>
>> When I run 'ant' on a fresh copy of the Flex SDK repo, I get the
>>following
>> error:
>>
>> [error]
>> download-osmf-swc:
>>       [get] Getting:
>>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fsourcefo
>>rge.net%2Fadobe%2F&data=02%7C01%7C%7C42c429a4a4cc4f45da1a08d506700aca%7Cf
>>a7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636422000644802646&sdata=HZ8U5z
>>yQfZxfUM%2BWeWwJAnAf8D6%2Bi6goRcMFZtd%2BQzk%3D&reserved=0
>> flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw
>>       [get] To: /Users/erik/Desktop/royale/flex-sdk/in/osmf.swc
>>       [get] Error getting
>>https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fsourcefo
>>rge.net%2Fadobe%2F&data=02%7C01%7C%7C42c429a4a4cc4f45da1a08d506700aca%7Cf
>>a7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636422000644802646&sdata=HZ8U5z
>>yQfZxfUM%2BWeWwJAnAf8D6%2Bi6goRcMFZtd%2BQzk%3D&reserved=0
>> flexsdk/code/HEAD/tree/trunk/frameworks/libs/OSMF2_0.swc?format=raw to
>> /Users/erik/Desktop/royale/flex-sdk/in/osmf.swc
>>
>> double-check-file:
>>      [echo] Need file: ${still_no_file}
>>
>> get-from-cache-if-needed:
>>
>> fail-if-not-found:
>>
>> BUILD FAILED
>> /Users/erik/Desktop/royale/flex-sdk/build.xml:157: The following error
>> occurred while executing this line:
>> /Users/erik/Desktop/royale/flex-sdk/frameworks/build.xml:100: The
>> following error occurred while executing this line:
>> /Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:105: The
>> following error occurred while executing this line:
>> /Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:117: The
>> following error occurred while executing this line:
>> /Users/erik/Desktop/royale/flex-sdk/frameworks/downloads.xml:422:
>> osmf.swc could not be downloaded or found in cache
>> [/error]
>>
>> I think I remember this happening way back when as well, but I don't
>> remember the workaround/fix. Help?
>>
>> Thanks,
>>
>> EdB
>>
>>
>>
>> --
>> Ix Multimedia Software
>>
>> Jan Luykenstraat 27
>> 3521 VB Utrecht
>>
>> T. 06-51952295 <06%2051952295>
>> I.
>>https://na01.safelinks.protection.outlook.com/?url=www.ixsoftware.nl&data
>>=02%7C01%7C%7C42c429a4a4cc4f45da1a08d506700aca%7Cfa7b1b5a7b34438794aed2c1
>>78decee1%7C0%7C0%7C636422000644802646&sdata=hGdVJRZGRxINv7nWrkxuZQ4wvfUdq
>>AYduuCsG1ejrYo%3D&reserved=0
>>
>
>
>
>--
>Ix Multimedia Software
>
>Jan Luykenstraat 27
>3521 VB Utrecht
>
>T. 06-51952295
>I.
>https://na01.safelinks.protection.outlook.com/?url=www.ixsoftware.nl&data=
>02%7C01%7C%7C42c429a4a4cc4f45da1a08d506700aca%7Cfa7b1b5a7b34438794aed2c178
>decee1%7C0%7C0%7C636422000644802646&sdata=hGdVJRZGRxINv7nWrkxuZQ4wvfUdqAYd
>uuCsG1ejrYo%3D&reserved=0

Reply | Threaded
Open this post in threaded view
|

Re: OSMF download fails when running 'ant'

Erik de Bruin
Hi,

That is a problem, but for Royale, we should stop requiring the flex-sdk
> repo and just use Apache Flex release bits.
>

For now, it's way easier to simply make the code run and let devs get set
up with a workable Royale SDK by following the steps in the READme.

And since this is a Flex issue - the SDK doesn't build anymore - this is
the place for this report, right?

EdB



--
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl