Unable to install Apache Flex SDK Installer on macOS Catalina

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to install Apache Flex SDK Installer on macOS Catalina

wimdeblauwe
Hello,

I just downloaded the latest Apache Flex SDK Installer from
http://flex.apache.org/installer.html which is verion 3.3.2 at the time of
writing.

When I tried to install it on my macBook Pro using macOS Catalina 10.15.2,
I get the following message:

*This application requires an update to Adobe AIR that is not available for
your system. Please view the system requirements
<http://www.adobe.com/go/air_sysreqs/> for Adobe AIR and update your system
accordingly.*


The link opens http://www.adobe.com/go/air_sysreqs/ but that just redirects
to https://www.adobe.com/404.html immediately.


How can I install the Flex SDK on my computer?


regards,


Wim
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install Apache Flex SDK Installer on macOS Catalina

Alex Harui-2
I don't have access to Catalina.  I guess I would try making sure that all versions of the Apache Flex SDK Installer have been uninstalled.  Then go to Adobe or Harman and get the latest version of AIR and install that first.  Then try installing the Installer again.  Some folks were complaining of this message recently: https://community.adobe.com/t5/air/air-runtime-installation-failed/td-p/10481129

You can also use Apache Ant to install the Apache Flex SDK.  

HTH
-Alex

´╗┐On 12/19/19, 6:05 AM, "Wim Deblauwe" <[hidden email]> wrote:

    Hello,
   
    I just downloaded the latest Apache Flex SDK Installer from
    https://nam04.safelinks.protection.outlook.com/?url=http%3A%2F%2Fflex.apache.org%2Finstaller.html&amp;data=02%7C01%7Caharui%40adobe.com%7C0337b7cf579e4eac395908d7848c840b%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C1%7C637123611358342901&amp;sdata=ugzeXHR23nQ9W5hqv4wTIJJU2aVoYA4l7y5vbbIxhlM%3D&amp;reserved=0 which is verion 3.3.2 at the time of
    writing.
   
    When I tried to install it on my macBook Pro using macOS Catalina 10.15.2,
    I get the following message:
   
    *This application requires an update to Adobe AIR that is not available for
    your system. Please view the system requirements
    <http://www.adobe.com/go/air_sysreqs/> for Adobe AIR and update your system
    accordingly.*
   
   
    The link opens http://www.adobe.com/go/air_sysreqs/ but that just redirects
    to https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.adobe.com%2F404.html&amp;data=02%7C01%7Caharui%40adobe.com%7C0337b7cf579e4eac395908d7848c840b%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C1%7C637123611358342901&amp;sdata=v9nLXAzmGEW0Nw5PuXU1Ul0jPj2PHYYeIPaO%2BTpryO0%3D&amp;reserved=0 immediately.
   
   
    How can I install the Flex SDK on my computer?
   
   
    regards,
   
   
    Wim
   

Reply | Threaded
Open this post in threaded view
|

RE: Unable to install Apache Flex SDK Installer on macOS Catalina

Jason Taylor-2
In reply to this post by wimdeblauwe
with the update to OSX 10.15, Apple made changes to the file system security that is blocking installation of the Dedoose Desktop App.  However, the following fix bypasses this:
Open Terminal, and paste the following the press enter
cd /Library/Frameworks
then paste the following line and press enter, note you may be required to enter your password
sudo xattr -r -d com.apple.quarantine ./Adobe\ AIR.framework

this command tells OSX to allow Adobe Air Apps to run on OSX Catalina

~ JT

-----Original Message-----
From: Wim Deblauwe <[hidden email]>
Sent: Thursday, December 19, 2019 6:05 AM
To: [hidden email]
Subject: Unable to install Apache Flex SDK Installer on macOS Catalina

Hello,

I just downloaded the latest Apache Flex SDK Installer from http://flex.apache.org/installer.html which is verion 3.3.2 at the time of writing.

When I tried to install it on my macBook Pro using macOS Catalina 10.15.2, I get the following message:

*This application requires an update to Adobe AIR that is not available for your system. Please view the system requirements <http://www.adobe.com/go/air_sysreqs/> for Adobe AIR and update your system
accordingly.*


The link opens http://www.adobe.com/go/air_sysreqs/ but that just redirects to https://www.adobe.com/404.html immediately.


How can I install the Flex SDK on my computer?


regards,


Wim